RELENG_7: swap_pager_getswapspace(3): failed

Kris Kennaway kris at FreeBSD.org
Mon Nov 12 02:21:56 PST 2007


Beech Rintoul wrote:
> On Monday 12 November 2007, Kris Kennaway said:
>> Beech Rintoul wrote:
>>> On Sunday 11 November 2007, mustkaru said:
>>>> On Nov 11, 2007 10:47 PM, Kris Kennaway <kris at freebsd.org> wrote:
>>>>> mustkaru wrote:
>>>>>> Hi,
>>>>>>
>>>>>> I updated to RELENG_7 two yesterday, and under usual load
>>>>>> started getting hundreds of messages
>>>>>>
>>>>>> swap_pager_getswapspace(3): failed
>>>>>>
>>>>>> The system swap is 96% full; it is less than 20% usually under
>>>>>> the same load. The system started to kill off processes
>>>>>> because of lack of swap space:
>>>>>>
>>>>>> pid 52606 (thunderbird-bin), uid 1001, was killed: out of swap
>>>>>> space swap_pager_getswapspace(2): failed
>>>>>> pid 13984 (evince), uid 1001, was killed: out of swap space
>>>>>>
>>>>>> I suppose there's no way to get back to the more stable BETA2
>>>>>> ? When cvsuping, I noticed
>>>>>>
>>>>>> 52815 Nov  8 14:03 vm_page.c
>>>>>>
>>>>>> had been changed. Might it be related to that? Might a next
>>>>>> possible change in that get back a more stable swapper. . .?
>>>>> This means you ran out of swap space because applications were
>>>>> requesting more virtual memory than your system contains.  This
>>>>> is an application issue, not a kernel issue.
>>>>>
>>>>> Kris
>>>> I hope so. It is weird though that I run exactly the same number
>>>> of applications every day; and I ran the same binary apps on an
>>>> earlier version of RELENG_7 (I updated system but not apps), but
>>>> I never ran out of swap space; in particular I have never used
>>>> more than .5 GB swap. This time, the system was using 1 GB swap.
>>>> So I suppose I should start hunting the guilty app.
>>> I'm seeing the exact same thing. I'm running -current from
>>> yesterday and this box is lightly loaded. I can't track it down
>>> to a specific process, but all of a sudden normal compiles are
>>> running me out of vm. This box has 500Mb ram and a gig of swap
>>> and has never run out of memory before. None of my applications
>>> have changed. I'm also starting to see it on a client's box I
>>> recently updated to 7.0, That box has 1Gb ram and 2Gb swap and is
>>> just a desktop and mailserver. I don't think this is application
>>> related.
>> Then you have further investigation to do to prove that theory :)
>>
>> Kris
> 
> I'd be happy to. All the processes on both boxes look normal. I 
> suspected either kde or xorg, but everything looks ok. Point me in 
> the right direction and I'll troubleshoot all I can. I do know we 
> have a problem, if it's not related to vm_page.c, then we have a very 
> evil application that is common to all.

Start by characterizing exactly what applications are using up all of 
memory and then proceed to studying what they are doing when the memory 
use grows.

Kris


More information about the freebsd-current mailing list