nfe internet problems

Chuck Robey chuckr at chuckr.org
Sun Nov 11 18:40:37 PST 2007


Pyun YongHyeon wrote:
> On Sun, Nov 11, 2007 at 02:52:24PM -0500, Chuck Robey wrote:
>  > I have a junko, but reliable, Ethernet card, one that has installed 
>  > perfectly as dc0, and runs fine.  I've been recently experimenting with 
>  > on-board peripherals, and since I have a Asus Striker Extreme mobo, I 
>  > thought that the dual Ethernet ports ought to work.  The dmesg output 
>  > seems to probe nfe0 & nfe1 just fine, so I tried using ifconfig (an old 
>  > friend, so you can dismiss thoughts that I did this wrong) to drop the 
>  > dc0, and move my stuff over to nfe0.  When I do this, the entire machine 
>  > instantly locks up solid.  I've tried this 3 times now; the machine 
>  > doesn't respond to pings, I can't (even typing in the blind) bring dc0 
>  > back to life, and it just seems to instantly lock up.
>  > 
>  > Any suggestions on this?
> 
> Please show me more information.
>  - FreeBSD version     
>  - verbosed boot messages
>  - ifconfig nfe0 output
>  - vmstat -i output

I guess I was asking about any known, general instability with the nfe
driver, and not even considering that it might be something I have
somehow screwed up, but you're obviously right, so here's the requested
data dump:

uname -a reads:  FreeBSD april.chuckr.org 8.0-CURRENT FreeBSD
8.0-CURRENT #0: Sat Nov  3 13:46:50 EDT 2007
root at april.chuckr.org:/usr/obj/s6/sys/APRIL  i386

I can't show you the nfe ifconfig, cause soon as I turn the nfe 0 or 1
to up, my box becomes a doorstop  I will give you the ifconfig out of my
dc0, because when I set it up, I do it identically.  I have tried doing
it manually, and also tried editing rc.conf so that it comes up
automatically (oh, recovering from that one is cute).  Here's the
ifconfig, which I believe is pretty useless ....

ifconfig dc0:

dc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
         options=8<VLAN_MTU>
         ether 00:0c:41:1b:e3:5c
         inet 66.92.151.30 netmask 0xffffff00 broadcast 66.92.151.255
         media: Ethernet autoselect (100baseTX <full-duplex>)
         status: active

Chances of my getting that one wrong are pretty remote, I'm fairly good
at commo stuff.

TCSH-april:chuckr:/usr/ports/lang:#13120:53>vmstat -i
interrupt                          total       rate
irq1: atkbd0                      194002          0
irq12: psm0                      1088361          2
irq14: ata0                         9913          0
irq16: dc0 atapci+               6104969         13
irq19: fwohci0                         3          0
irq22: pcm0 ehci0                 918638          2
cpu0: timer                    885224650       1999
cpu1: timer                    885215957       1999
cpu2: timer                    885215978       1999
cpu3: timer                    885215959       1999
Total                         3549188430       8018

OK, I just finished getting a verbose boot.  Wouldn't you know it?  The 
nfe ports aren't even recognized now.  I have them static in the kernel 
(so they don't need kldloading) but I can offer you no probing info.  I 
can find the nfe by using kldstat -v, so it's in the kernel (and i 
checked, an attempt to load it anyhow fails).  I haven't any idea why it 
would not be probed, it's on the motherboard (an Asus Striker Extreme) 
and needs only to have the bios agree to allow it, which it was.  Hmm, I 
think I will reboot and check the bios again anyhow.  Won't hurt 
anything, I guess.



More information about the freebsd-current mailing list