Panic with wi0

David Wolfskill david at catwhisker.org
Sun Nov 11 15:24:33 PST 2007


On Sun, Nov 11, 2007 at 09:50:58AM -0500, Michael W. Lucas wrote:
> 
> Any thoughts, folks?

OK; I finally got around to building & booting today's CURRENT:

g1-1(8.0-C)[1] uname -a
FreeBSD g1-1.catwhisker.org. 8.0-CURRENT FreeBSD 8.0-CURRENT #588: Sun Nov 11 13:33:03 PST 2007     root at g1-1.catwhisker.org.:/common/S4/obj/usr/src/sys/CANARY  i386
g1-1(8.0-C)[2] 

As expected:

* No panic trying to probe or use the wi0 NIC.

* But it (still) doesn't associate, either:

g1-1(8.0-C)[6] ifconfig
xl0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9<RXCSUM,VLAN_MTU>
        ether 00:08:74:e5:95:cb
        media: Ethernet autoselect (none)
        status: no carrier
fwe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 46:4f:c0:76:40:41
        ch 1 dma -1
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        lladdr 44.4f.c0.0.30.76.40.41.a.2.ff.fe.0.0.0.0
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
        inet6 ::1 prefixlen 128 
        inet 127.0.0.1 netmask 0xff000000 
wi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:02:2d:5b:2c:78
        media: IEEE 802.11 Wireless Ethernet autoselect (none)
        status: no carrier
        ssid Sojourner channel 1 (2412 Mhz 11b)
        stationname "FreeBSD WaveLAN/IEEE node"
        authmode OPEN privacy ON deftxkey 1 wepkey 1:40-bit bmiss 7
        scanvalid 60 bintval 0
an0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:40:96:32:19:a9
        inet 172.17.1.1 netmask 0xffff0000 broadcast 172.17.255.255
        media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
        status: associated
        ssid  1:lmdhw-net channel 1 (2412 Mhz 11b)
        stationname FreeBSD
        authmode OPEN privacy ON deftxkey 1 txpower 0 rtsthreshold 0
        fragthreshold 0 bmiss 0 mcastrate 0 roaming DEVICE bintval 0
g1-1(8.0-C)[7] 

(The an0 NIC works, though it seems to lose connectivity; running
through the script I cobbled up to get the NIC associated seems to
help,, though I sometimes need to ifconfig it  down, then up first.)

This behavior is the same for me in HEAD & RELENG_7; for RELENG_6, the
wi0 NIC (which in my laptop's case is a miniPCI card) works fine.

Peace,
david
-- 
David H. Wolfskill				david at catwhisker.org
Proprietary data formats obfuscate, rather than disseminate, information.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20071111/daef608b/attachment.pgp


More information about the freebsd-current mailing list