Recent update of 7-BETA causes laptop to freeze on battery

Kevin Oberman oberman at
Wed Nov 7 21:30:10 PST 2007

On Nov. 7, 2007, Kevin Oberman wrote:

> After an update of my laptop to 7-BETA2 on Nov. 4, I can no longer run
> on battery. If I boot on battery, everything is normal until devd is
> started. It immediately fires off /etc/rc.d/power_profile which
> sets my system to C4.
> Once this happens, the system almost freezes. It takes about 15 seconds
> to move on the ipfw and, after the initial "Flushed all rules" it pauses
> for another 20-30 seconds and loads rules by ones and twos before
> finally totally freezing. Ctrl-C will cause a several more lines to come
> out, but it never makes it to multiuser mode.
> If I plug it in, it often eventually switches back to C1 and runs
> normally. Pulling the plug again switches back to C4 and everything
> locks up. I eventually gave up and power cycled the system. (Ugh!) It
> may be an issue with output to the console as, if it unfreezes at all,
> it usually spits out several lines to the console at once before another
> pause.
> This has not been a problem until recently. My last known working kernel
> was from back on about Oct. 15, although I think one from back on Oct 29
> also worked. (Just not sure that I had it on battery.)
> Any ideas on where to look for this and how to debug? If forces me to
> leave the CX state at HIGHEST (C1) all the time with kills the battery.

I've learned a bit more about the problem.

I have discovered that this is tied to the syscons. If I set cx_lowest
to C3 or C4 in X, it works fine. If I set it while in syscons, the
system almost completely locks up. If I have cx_lowest set to C3 and
shut down my X session, it fails as soon as it drops into syscons. I get
a few lines of output and then it hangs for a very long time. After
several minutes I could get logged onto another vty and change
dev.cpu.0.cx_lowest to C1 which made it all work again.

Since it might be scheduler related, I should mention that I run
SCHED_ULE on an 2 GHz T43 (Pentium-M).

Has anyone else seen this?
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at			Phone: +1 510 486-8634
Key fingerprint:059B 2DDF 031C 9BA3 14A4  EADA 927D EBB3 987B 3751

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 224 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list