Remaining SATA (and other) issues

Nathan Butcher n-butcher at fusiongol.com
Wed Nov 7 18:09:09 PST 2007


Just chiming in here about my SATA controller status in FreeBSD7 BETA2.

I have a Gigabyte GA-G33-D3SR, and I am running 6 drives ICH9 in AHCI
mode (I am able to set the mode in the BIOS) with ZFS. No problems here
at all. ICH9 works fine for me.

My Jmicron SATA controller is in AHCI mode (as set in the BIOS) - hrm...
not sure about hard drives working in this controller as I am using a
SATA DVD drive in mine. I can mount a data DVD/CD into the filesystem
and read it, although as many people noted, burncd just isn't working yet.

I have a SiI 3124 chipset generic SATA II card in my machine which works
flawlessly at the moment. Anyone looking for a cheap, working SATA II
controller should look at this one.

My Promise SATA 300 TX4 (and SATA 150 TX4) is still not working,
although I am not really using it at the moment. I know Soren is working
on it. I'd be more than happy to test any patches, as I'm following
RELENG_7 quite closely.

If it were possible to send beer over email, Soren deserves it. Thanks
for all your work.

Some other lingering things I've noticed in BETA2 :-

* My machine randomly froze and rebooted itself last night. I had X
running, and I think that's the cause.... maybe....
* G33 video chipset support... coming in RELENG_7?
* I have a ural chipset wireless USB adapter. I connect with DHCP. The
adapter works mostly, but sometimes it randomly locks up and no packets
get through - until I restart another connection usually.



More information about the freebsd-current mailing list