powerd adaptive mode latching

Russell Jackson raj at csub.edu
Sun Nov 4 21:01:25 PST 2007


Powerd seems to latch at the maximum - 1 cpufreq setting while in 
adaptive mode. This is 100% reproducible for me. It never un-wedges from 
this state no matter how long I wait.

$ powerd -a adaptive -b adaptive -v
powerd: using sysctl for AC line status
powerd: using devd for AC line status
idle time > 90%, decreasing clock speed from 1289 MHz to 966 MHz
idle time > 90%, decreasing clock speed from 966 MHz to 644 MHz
idle time > 90%, decreasing clock speed from 644 MHz to 322 MHz
idle time < 65%, increasing clock speed from 322 MHz to 966 MHz
idle time > 90%, decreasing clock speed from 966 MHz to 644 MHz
idle time > 90%, decreasing clock speed from 644 MHz to 322 MHz
idle time < 65%, increasing clock speed from 322 MHz to 966 MHz
idle time < 65%, increasing clock speed from 966 MHz to 1611 MHz
idle time < 65%, increasing clock speed from 1611 MHz to 2255 MHz
idle time < 65%, increasing clock speed from 2255 MHz to 2579 MHz
idle time > 90%, decreasing clock speed from 2579 MHz to 2578 MHz
idle time > 90%, decreasing clock speed from 2579 MHz to 2578 MHz
idle time > 90%, decreasing clock speed from 2579 MHz to 2578 MHz
.
.
.

$ sysctl dev.cpu
dev.cpu.0.%desc: ACPI CPU
dev.cpu.0.%driver: cpu
dev.cpu.0.%location: handle=\_PR_.CPU0
dev.cpu.0.%pnpinfo: _HID=none _UID=0
dev.cpu.0.%parent: acpi0
dev.cpu.0.freq: 1289
dev.cpu.0.freq_levels: 2579/-1 2578/-1 2255/-1 1933/-1 1611/-1 1289/-1 
966/-1 644/-1 322/-1
dev.cpu.0.cx_supported: C1/1 C2/1 C3/85 C4/185
dev.cpu.0.cx_lowest: C3
dev.cpu.0.cx_usage: 0.00% 100.00% 0.00% 0.00%

$ sysctl dev.ichss
dev.ichss.0.%desc: SpeedStep ICH
dev.ichss.0.%driver: ichss
dev.ichss.0.%parent: cpu0
dev.ichss.0.freq_settings: 2579/-1 2578/-1

The ichss levels looked odd to me, and trying to set cpufreq=2578 is a NOOP.

$ sysctl dev.cpu.0.freq=2578
dev.cpu.0.freq: 2579 -> 2579

I'm running 7_RELENG from about a week ago. dmesg.boot attached.

-- 
Russell A. Jackson <raj at csub.edu>
Network Analyst
California State University, Bakersfield
-------------- next part --------------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-BETA1 #0: Wed Oct 24 01:37:58 PDT 2007
    raj at strider.homelan:/usr/obj/usr/src/sys/MONOLITH
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Mobile Intel(R) Pentium(R) 4 - M CPU 2.60GHz (2591.60-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
  Features=0xbfebf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x4400<CNXT-ID,xTPR>
real memory  = 670752768 (639 MB)
avail memory = 642727936 (612 MB)
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <DELL CPi R  > on motherboard
acpi0: [ITHREAD]
acpi0: reservation of 0, 9fc00 (3) failed
acpi0: reservation of 100000, 27ef0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
acpi_perf0: failed in PERF_STATUS attach
device_attach: acpi_perf0 attach returned 6
p4tcc0: <CPU Frequency Thermal Control> on cpu0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
acpi_perf0: failed in PERF_STATUS attach
device_attach: acpi_perf0 attach returned 6
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
battery1: <ACPI Control Method Battery> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci_link1: BIOS IRQ 11 for 0.31.INTB is invalid
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> on hostb0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xc000-0xc0ff mem 0xe8000000-0xefffffff,0xfcff0000-0xfcffffff irq 11 at device 0.0 on pci1
acpi_video0: <ACPI video extension> on vgapci0
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xbf80-0xbf9f irq 11 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
uhci0: [ITHREAD]
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xbf40-0xbf5f irq 11 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
uhci1: [ITHREAD]
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xbf20-0xbf3f irq 11 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
uhci2: [ITHREAD]
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
ehci0: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> mem 0xf4fffc00-0xf4ffffff irq 11 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb3
uhub3: 6 ports with 6 removable, self powered
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci_link1: BIOS IRQ 11 for 2.3.INTA is invalid
pci2: <ACPI PCI bus> on pcib2
bfe0: <Broadcom BCM4401 Fast Ethernet> mem 0xfaffe000-0xfaffffff irq 11 at device 0.0 on pci2
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> PHY 1 on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: using obsoleted if_watchdog interface
bfe0: Ethernet address: 00:0d:56:35:9d:04
bfe0: [ITHREAD]
cbb0: <TI4510 PCI-CardBus Bridge> at device 1.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb0: [ITHREAD]
fwohci0: <1394 Open Host Controller Interface> mem 0xfaffd800-0xfaffdfff,0xfaff8000-0xfaffbfff irq 11 at device 1.1 on pci2
fwohci0: [FILTER]
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 44:4f:c0:00:07:92:d0:61
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 46:4f:c0:92:d0:61
fwe0: Ethernet address: 46:4f:c0:92:d0:61
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 44:4f:c0:00:07:92:d0:61 @ 0xfffe00000000, S400, maxrec 2048
sbp0: <SBP-2/SCSI over FireWire> on firewire0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x1404000
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
ath0: <Atheros 5212> mem 0xfafe0000-0xfafeffff irq 9 at device 3.0 on pci2
ath0: [ITHREAD]
ath0: using obsoleted if_watchdog interface
ath0: Ethernet address: 00:0b:6b:37:ae:8b
ath0: mac 5.9 phy 4.3 radio 3.6
ichss: enabling SpeedStep support
ichss: enabling SpeedStep support
ichss0: <SpeedStep ICH> on cpu0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xbfa0-0xbfaf at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
pcm0: <Intel ICH4 (82801DB)> port 0xb800-0xb8ff,0xbc40-0xbc7f mem 0xf4fff800-0xf4fff9ff,0xf4fff400-0xf4fff4ff irq 9 at device 31.5 on pci0
pcm0: [ITHREAD]
pcm0: <SigmaTel STAC9750/51 AC97 Codec>
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model GlidePoint, device ID 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio0: [FILTER]
sio1 port 0x2f8-0x2ff,0x280-0x287 irq 3 drq 3 on acpi0
sio1: type 16550A
sio1: [FILTER]
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcffff pnpid ORM0000 on isa0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ppc0: [GIANT-LOCKED]
ppc0: [ITHREAD]
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2591599868 Hz quality 800
Timecounters tick every 1.000 msec
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
ad0: 28615MB <TOSHIBA MK3021GAS GA129D> at ata0-master UDMA100
acd0: DVDROM <TOSHIBA DVD-ROM SD-C2612/1D21> at ata1-master UDMA33
Trying to mount root from ufs:/dev/ad0s1a
WARNING: / was not properly dismounted
WARNING: /tmp was not properly dismounted
WARNING: /usr was not properly dismounted
WARNING: /var was not properly dismounted


More information about the freebsd-current mailing list