[RFT] Intel 3945abg wireless driver (wpi)

Lars Engels lme at FreeBSD.org
Sun Nov 4 02:28:05 PST 2007


On Fri, Nov 02, 2007 at 11:48:21AM +1030, Benjamin Close wrote:
> Max Laier wrote:
> >On Friday 02 November 2007, Lars Engels wrote:
> >  
> >>On Fri, Nov 02, 2007 at 10:23:44AM +1030, Benjamin Close wrote:
> >>    
> >>>Howdy All,           I'm pleased to announce the first 'official'
> >>>experimental version of the wpi wireless driver and hence require
> >>>your help in making it become stable.
> >>>Expect a few things not to work (ie bg scanning, setting txpower) but
> >>>in general the driver should be usable in station mode (hostap is not
> >>>yet supported).
> >>>
> >>>If you've got an Intel 3945abg wireless card, grab the tarball at:
> >>>
> >>>  http://people.freebsd.org/~benjsc/downloads/wpi/20071102-freebsd-wpi.
> >>>tar.gz
> >>>
> >>>Untar and follow the instructions in the README.
> >>>If you want more info about the driver, or to checkout the FAQ
> >>>checkout:
> >>>
> >>>   http://www.clearchain.com/wiki/Wpi
> >>>
> >>>I'm interested in all reports related to panics, things not working
> >>>as expected, etc. The driver still has debug enabled so expect a few
> >>>messages to be dumped to the screen whilst in use.
> >>>
> >>>Finally, many thanks to all those that have been helping debug the
> >>>driver along the way.
> >>>
> >>>Cheers,
> >>>   Benjamin
> >>>      
> >>Good to know that someone is still working on it.
> >>However, it doesn't work for me. I cannot load the firmware:
> >>
> >>lars at ttyp3 # kldload wpifw
> >>lars at ttyp3 # dmesg
> >>wpifw: You need to read the LICENSE file in
> >>/usr/share/doc/legal/intel_wpi/. wpifw: If you agree with the license,
> >>set legal.intel_wpi.license_ack=1 in /boot/loader.conf.
> >>module_register_init: MOD_LOAD (wpifw_fw, 0xc6d1151c, 0) error 1
> >>
> >>lars at ttyp3 # grep legal.intel_wpi.license_ack /boot/loader.conf
> >>legal.intel_wpi.license_ack=1
> >>
> >>lars at ttyp3 # sysctl legal
> >>sysctl: unknown oid 'legal'
> >>    
> >
> >It's not a sysctl it's in kenv, but if it's in loader.conf it should be in kenv, too.
> >
> >  
> >>And I even read the license! ;-)
> >>    
> >
> >
> >  
> You shouldn't need to manually kldload the wpifw, wpi will pull it in for you. However, if you have the line in loader.conf it should work - I take it you did reboot 
> for the setting to be grabbed?
> 

Sorry for the noise. I didn't reboot nor did I use kenv. It's working
now except for WPA. :)

Lars
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20071104/e9821982/attachment.pgp


More information about the freebsd-current mailing list