sata atapi on ich9r

Aryeh M. Friedman aryeh.friedman at
Sat Nov 3 05:48:06 PDT 2007

samira wrote:
> hi
> I have some problem using sata atapi devices on my gigabyte p35-ds4.

First of all p35 (ihc9r) have many known problems in this area (just for
reference I have a msi neon-f p35 mobo w/ e6850, 4 gig and 2 sata + 1
pata device).

When I first got the machine back in august it had all kinds of issues
(do a search of -questions and -current to see them all).  Most of the
critical ones have been resolved post -current version fork.
> The controller is in ahci mode. There are two kinds of dvd-devices
>  1). DVDROM <ASUS DVD-E616A3T/1.11>
>  2). DVDR <Optiarc DVD RW AD-7170S/1.00>
> System is a 7.0-BETA2.

What kind of processor and is the kernel/bases system i386 or amd64?

Are you SATA/300 devices reported as SATA/150 and/or UDMA33?

Does it reconize any PATA devices you may have?

The only solution I was found was to use 8-current (i.e. from late sept
on wards stuff worked fine [but only after the version fork]).   BTW my
SATA/300 devices are still reported as SATA/150 and the PATA device is
not seen at all.
> If I have "atapicam" in the kernel, the system freezes at boot, well
> not exactly freezing, but giving
>  acd0: FAILURE - INQURY timed out
>  acd0: FAILURE - INQURY timed out
> over and over, where acd0 is one of the asus dvd drives.

Same issue on amd64 beta 1.5 for me (but i386 worked fine [I had to do
open heart surgery to switch it to amd64 [note 1]])
> Removing atapicam from kernel does help. I can boot, provided there
> are no cds/dvds in the drives.
> But trying to play a dvd fails with
>  acd0: WARNING - SETFEATURES SET TRANSFER MODE taskqueue timeout -
> completing request directly
>  acd0: WARNING - SETFEATURES SET TRANSFER MODE taskqueue timeout -
> completing request directly
>  acd0: FAILURE - SEND_KEY timed out
>  acd0: FAILURE - MODE_SENSE_BIG timed out
> no matter, if I try on optiarc/asus.

Is this true even if you have boot from cd in the cmos?
> I can mount data cds. But the system freezes for about one minute
> when doing so.

I have not experienced this but then again I never tried it ;-)

Note to the development team:   No I was not tripping when I reported
these same issues just unable to provide proof

Note to sam: Do you have any development experience if so I invite you
to help me in my current project to patch the ata driver to fix all
these issues (the ata developer told me since he doesn't have access to
a ich9r/p35 system no patch and/or cvsup would be forth coming on these
issues)... I am also a developer but at the moment am very tied up with
making a living so I will give what help I can but can't do the whole
project alone


1. Procedure:

Downgrade to 6.2 amd64
FTP the distfiles for base and kernel (networking is completely broken
so you have do some very creative tricks to get transfers to complete
[note to the "no evidence" crowd on this list this is my ONLY machine
and since it was so @#$@#$'ed up before the reupgrade to 8-current I was
not able to record any proof of this])
overwrite the base and kernel with the distfiles
do the stay current procedure in the handbook

More information about the freebsd-current mailing list