X crash with radeon driver - AGP broken?

Simias simias.n at gmail.com
Fri Nov 2 23:27:31 PDT 2007


Hi

Since I csup'd 7.0-BETA1, my computer reboots when I startx with the
(open source) radeon driver -- I also tried with a fresh -CURRENT with the
same result.

It's probably not the place for asking X related questions, however it
worked fine till then with a -CURRENT from mid-september (with the same
Xorg 7.3), and here's the last output I get before it reboots:

,----[ startx -- -verbose 10 -config back/xorg.conf.radeon ]
|                          [...]
| (==) RADEON(0): Using 24 bit depth buffer
| (II) RADEON(0): RADEONInitMemoryMap() :
| (II) RADEON(0):   mem_size         : 0x10000000
| (II) RADEON(0):   MC_FB_LOCATION   : 0xcfffc000
| (II) RADEON(0):   MC_AGP_LOCATION  : 0xffffffc0
| (II) RADEON(0): Depth moves disabled by default
| (II) RADEON(0): Setting up initial surfaces
| (II) RADEON(0): Setting up accel memmap
| (II) RADEON(0): CP in BM mode
| (II) RADEON(0): Using 8 MB GART aperture
| (II) RADEON(0): Using 1 MB for the ring buffer
| (II) RADEON(0): Using 2 MB for vertex/indirect buffers
| (II) RADEON(0): Using 5 MB for GART textures
| (II) RADEON(0): Memory manager initialized to (0,0) (3072,8191)
| (II) RADEON(0): Reserved area from (0,1440) to (3072,1442)
| (II) RADEON(0): Largest offscreen area available: 3072 x 6749
| (II) RADEON(0): Will use front buffer at offset 0x0
| (II) RADEON(0): Will use back buffer at offset 0x4620000
| (II) RADEON(0): Will use depth buffer at offset 0x5700000
| (II) RADEON(0): Will use 155648 kb for textures at offset 0x67e0000
| drmOpenDevice: node name is /dev/dri/card0
| drmOpenDevice: open result is 8, (OK)
| drmOpenDevice: node name is /dev/dri/card0
| drmOpenDevice: open result is 8, (OK)
| drmOpenByBusid: Searching for BusID pci:0000:03:00.0
| drmOpenDevice: node name is /dev/dri/card0
| drmOpenDevice: open result is 8, (OK)
| drmOpenByBusid: drmOpenMinor returns 8
| drmOpenByBusid: drmGetBusid reports pci:0000:03:00.0
| (II) [drm] DRM interface version 1.2
| (II) [drm] DRM open master succeeded.
| (II) RADEON(0): [drm] Using the DRM lock SAREA also for drawables.
| (II) RADEON(0): [drm] framebuffer handle = 0xc0000000
| (II) RADEON(0): [drm] added 1 reserved context for kernel
| (II) RADEON(0): X context handle = 0x1
| (II) RADEON(0): [drm] installed DRM signal handler
| (==) RADEON(0): Using AGP 8x
| (II) RADEON(0): [agp] Mode 0x1f00420a [AGP 0x0000/0x0000; Card 0x1002/0x4150]
| (II) RADEON(0): [agp] 8192 kB allocated with handle 0xc4128700
`----

It seems to break in AGP related init (or just after that, I don't
know).

It works fine with VESA, so I wonder if I'm the only one with this
problem and if you have any idea about how to fix this or to investigate
further the problem. (I tried to rebuild everything that could possibly
be rebuilt).

,----
| $ uname -a FreeBSD simias.hd.free.fr 7.0-BETA1 FreeBSD 7.0-BETA1 #0: Mon
| Oct 29 07:16:53 CET 2007
| root at simias.hd.free.fr:/usr/obj/usr/src/sys/HOMEBOX_ATHLON i386
| 
| $ X -version
| X.Org X Server 1.4.0
| Release Date: 5 September 2007
| X Protocol Version 11, Revision 0
| Build Operating System: FreeBSD 7.0-BETA1 i386 
| Current Operating System: FreeBSD simias.hd.free.fr 7.0-BETA1 FreeBSD
| 7.0-BETA1 #0: Mon Oct 29 07:16:53 CET 2007
| root at simias.hd.free.fr:/usr/obj/usr/src/sys/HOMEBOX_ATHLON i386
| Build Date: 27 October 2007  10:45:02AM
|  
| 	Before reporting problems, check http://wiki.x.org
| 	to make sure that you have the latest version.
| Module Loader present
`----

My radeon is a 9600 Pro.

Any clue ?

--
Simias


More information about the freebsd-current mailing list