problems: nvidia latest driver and 7.0-BETA1

Bruce Cran bruce at cran.org.uk
Fri Nov 2 16:42:27 PDT 2007


Stefan Lambrev wrote:
> Hi,
> 
> Nenhum_de_Nos wrote:
>> On 10/31/07, Stefan Lambrev <stefan.lambrev at moneybookers.com> wrote:
>>  
>>> add to /boot/loader.conf
>>> nvidia_load="YES"
>>> and reboot.
>>> May be you have device vga which blocks access to the card, so if you
>>> load nvidia module before the kernel ..
>>>     
>>
>> i did it, and no good :(
>>
>> Michal Varga :
>>
>> this is a GeForce Go 7600 PCIe from an asus F3T notebook. when I
>> installed the port, I didnt marl to use FreeBSD agp driver. so by this
>> info I assume I'm using nvidia's. is that right ?
>>
>> it is really annoying using without the driver, I cant even watch a
>> video. frame dropping and everything is slow :(
>>
>> I also tried the 97xx driver and no luck also :(
>>
>> matheus
>>
>>   
> Well I'm not sure what exactly is your problem, but this is how I get my 
> driver working:
> /boot/loader.conf
> nvidia_load="YES"
> linux_load="YES"
> 
> cd /usr/ports/x11/nvidia-driver && make config
> everything except AGP is selected.
> 
> I'm using and this sysctl - compat.linux.osrelease=2.6.16
> but nvidia driver should work without problems with default 2.4.2.
> 
> And your card is too new to use legacy driver :) just go for the latest.
> 
> Also if your card is detected you should have hw.nvidia.cards.0.XX too.
> 
> can you provide dmesg and pciconf -vl ?
> 

I was just about to post saying that I had the same problem, but before 
doing so I made sure I'd got a recent kernel+world and upgraded all the 
ports.  As I was running the script session to capture all the data I 
realised it had worked this time.  My card's now detected and Xorg seems 
to be running fine.  Loading the driver once the system has booted 
doesn't seem to work (nothing gets shown in dmesg) but having the lines 
in /boot/loader.conf works for me.

--
Bruce


More information about the freebsd-current mailing list