Xorg 7.2 update

Marijn van Vliet w.m.vanvliet at student.utwente.nl
Sun May 27 22:18:55 UTC 2007

On 19:47, Sun 27 May 07, Claus Guttesen wrote:
> >I just updated my 6.2 box to the new Xorg 7.2 distro.  I followed all
> >the directions in the UPDATING file.  It appears all the directories
> >have been properly built.  I also successfully ran the "mergebase.sh"
> >script from the Tools/scripts directory.  However, when I try to run
> >X, I get the following error:
> >
> >(EE) Failed to load module "pcidata" (module does not exist), 0)
> >Fatal server error:
> >Unable to load required base modules, Exiting....
> I had the same error when I reused an old xorg.conf. I commented out
> some modules, until it worked. Don't remember which one though.

I had this and another problem when upgrading. This problem was sovled
by correcting the paths in xorg.conf. The other problem was a message
about the default font (fixed) not being found. This is solved by manually
reinstalling font-misc-misc and font-cursor-mic:
portupgrade -f font-misc-misc font-cursor-misc

Why this works, I have no idea. Do the fonts get corrupted by the
mergebase script? After some googling I noticed more users were having
this problem.

Marijn van Vliet

More information about the freebsd-current mailing list