Problem compiling xorg-server{-snap} on recent -CURRENT

Kris Kennaway kris at
Mon May 21 08:26:58 UTC 2007

On Sun, May 20, 2007 at 10:54:44PM -0500, Jonathan Fosburgh wrote:
> I am trying to upgrade my Xorg installation to 7.2.  I believe everything has 
> upgraded successfully except for xorg-server.  While trying to compile either 
> xorg-server port, the compilation process hangs in hw/xfree86/scanpci at 
> xf86ScanPci.c.  The compiler just sits there, rapidly chewing up about 800MB 
> of memory and doesn't proceed.  I am running -CURRENT from Saturday morning 
> CDT (approx 10AM), so this is post symver and post gcc-4.2.  I would imagine 
> this combination of software wasn't thoroughly tested.  My system is an 
> Athlon64 3200+ (running i386).   Uname output is:
> FreeBSD 7.0-CURRENT FreeBSD 7.0-CURRENT #3: Sat May 19 
> 12:16:39 CDT 2007     root@:/usr/obj/usr/src/sys/vmbsd  i386
> This is a very recently built system and quite clean in terms of what software 
> is installed, prior to upgrading to 7.2 I only had about 350 packages 
> installed, and the bulk of that was kde and support programs and libraries.
> Has anyone managed to compile xorg-server on a very recent -CURRENT?

It worked the last time I tried.  That was with gcc 4.2 but without
symver.  I cannot confirm how much memory it may have required though.


More information about the freebsd-current mailing list