if_ath breaks s3 suspend/resume [Was: ACPI S3 wakeup problem (beeeeeeeeep)]

Sam Leffler sam at errno.com
Thu May 10 02:16:38 UTC 2007


Kevin Oberman wrote:
>> Date: Wed, 9 May 2007 13:33:40 +0200
>> From: Alexander Leidinger <Alexander at Leidinger.net>
>> Sender: owner-freebsd-current at freebsd.org
>>
>> Quoting Louis Kowolowski <louisk at cryptomonkeys.com> (Tue, 8 May 2007 23:38:51 -0700):
>>
>>> On Tue, May 08, 2007 at 09:04:49PM -0700, Sam Leffler wrote:
>>>> Harald Schmalzbauer wrote:
>>>>> Am Dienstag, 8. Mai 2007 schrieb Harald Schmalzbauer:
>>>>>> Hello,
>>>>>>
>>>>>> I found the sysctl "debug.acpi.resume_beep" and enabled it.
>>>>>> When I send my Vaio SRX41p sleeping with acpiconf -s3 it never waked up
>>>>>> again. Now with this sysctl enabled I hear a continuing beep, but the 
>>>>>> hard drive stays powered down, also the LCD keeps unlit.
>>>>>>
>>>>>> Any hints how I can find out what's going wrong?
>>>>>> Tuning hw.acpi.reset_video doesn't change anything.
>>>>> Again, the fabulous handbook gave me the hint to remove all devices from
>>>>> the kernel and dynamically load them.
>>>>> This revealse if_ath as the culprit. (the last I tried after usb, 
>>>>> fwohci, pcm, ichsmb)
>>>>>
>>>>> Could this be related to the interrupt strom problems with ath (I often 
>>>>> get storm warnings, all drivers share IRQ9 on this laptop)?
>>>> Unclear but there's been an outstanding complaint against ath related to
>>>> suspend for a while.  Specifically if you touch certain registers in the
>>>> h/w after the chip has been put to sleep you can hang the pci bus.  I've
>>>> asked people that can reproduce the problem to narrow down the code path
>>>> by which the driver is entered but w/o luck.
>>>>
>>> I don't know for sure, but I think I might be seeing a similar issue with
>>> atheros, but during bootup instead of suspend.  It's not reproducable in a
>>> reliable fashion, but sometimes I get a hang during bootup shortly after 
>>> ath0 is brought up.  I also see an interupt storm on irq11, which I believe 
>>> is also shared by ichsmb (at least on my Thinkpad T60p).
>> AOL! Very hard hang. I have to remove the power supply and the battery
>> from my laptop then. I also get a message sometimes on the console (Sam
>> knows about it). The IRQ is also shared with something else, I think (I
>> have to look this up).
> 
> I knew there was a reason to not put if_ath in the kernel. (Actually, I
> want it out of the kernel so I can be sure the radio is not transmitting
> in flight or eating battery when I am on a wire or have no available AP.

ifconfig ath0 down turns the radio off; guaranteed.

> 
> On another note, you don't need to pull power/battery to do a hard reset
> on any remotely modern laptop. Just press and hold the power button for
> 5 seconds and your system will power down.

Always worked for me but like I said until someone tells me what's going
on or I can reproduce the problem myself it's going to sit on my todo list.

	Sam


More information about the freebsd-current mailing list