UPEK/TouchChip Biometric Device problem

Patrick Tracanelli eksffa at freebsdbrasil.com.br
Fri Jun 22 21:09:11 UTC 2007

Hello all,

I have used the mentioned devices on FreeBSD 5.4 in the past, and they 
worked just fine, but now I get problems with the same device, on top of 
6.2-STABLE and also 7.0-CURRENT.

 From `usbdevs -v`, I get:

Controller /dev/usb2:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000), 
Intel(0x0000), rev 1.00
  port 1 addr 2: full speed, power 100 mA, config 1, Biometric 
Coprocessor(0x2016), STMicroelectronics(0x0483), rev 0.01
  port 2 powered

I have security/bsp_upektfmess, security/pam_bsdbioapi and 
security/bioapi installed. It is a 6.2-STABLE system from 2 hours ago.

Listing bsp devices, I get:

# bbdm -l bsp
UUID {ffffffff-ffff-ffff-ffff-ffffffffffff}
          Example Vendor libbioapi_dummy100.so (BioAPI v1.1 Dummy BSP)
UUID {263a41e0-71eb-11d4-9c34-124037000000}
          BioAPI Consortium libpwbsp.so (BioAPI Password BSP)
UUID {5550454b-2054-464d-2f45-535320425350}
          UPEK, Inc. libtfmessbsp.so (TouchChip TFM/ESS Fingerprint BSP)

Backend configurations:

# bbdm -l birdb
Installed BIRDB modules
filedb   Filebacked database (b-tree)
plain    Plain text file

And now, the problem:

# bbdm -b "{5550454b-2054-464d-2f45-535320425350}" -m filedb -c eksffa
bbdm: Failed to initate BSP {5550454b-2054-464d-2f45-535320425350}

And on /var/log/messages as well as dmesg, I get:

All threads purged from ugen1.1
All threads purged from ugen1.2
All threads purged from ugen1.3

What is this about "threads purged"? Also, the port want libintl.so.6 
while 6.2-STABLE has libintl.so.8. I have tried 1) linking .8 to .6 and 
also copied .6 from another system (also, 6.2-STABLE) to the current 
one. Didnt work both way. Same behavior, exactly.

On 7.0-CURRENT things are worse. libpthread is not found, and the same 
command core dumps. Anyway, 6.2-STABLE is more important to me right 
now, since I need this device to work on FreeBSD for an ongoing project, 
but if a solution to 7.0 happens first my work can move to that version.

Can anyone help me?

Thank you.

Patrick Tracanelli

More information about the freebsd-current mailing list