wireless

Andrew Thompson andy at fud.org.nz
Thu Jun 21 04:40:49 UTC 2007


On Tue, Jun 19, 2007 at 10:25:38PM +0200, Pierre DAVID wrote:
> On Tue, Jun 19, 2007 at 01:19:08PM +1200, Andrew Thompson wrote:
> > Hi,
> > 
> > 
> > I am investigating a couple of wireless issues reported since the
> > net80211 changes were merged last week. I thought i'd list them out in
> > case any one else is looking into them (or wants to).
> > 
> > 1. Unloading the ath module hangs
> >    I have reproduced this but not found the cause yet, its a hard hang
> >    and I cant break into the debugger.
> > 
> > 2. Firmware iwi_bss will not load
> >    Loading the firmware for iwi causes an interrupt storm and times out.
> >    I havnt reproduced this and has only been reported by one person.
> > 
> > 3. iwi(4) gets a firmware error while associating
> >    Can not reproduce this yet, debug traces available on the mailing
> >    list.
> > 
> > 4. wi(4) fails to associate
> >    Unknown yet
> > 
> > 
> > Please report any other wireless issues and help is appreciated.
> > 
> 
> FreeBSD vagabond.ma.maison 7.0-CURRENT FreeBSD 7.0-CURRENT #27: Sat Jun 16 20:42:47 CEST 2007     pda at vagabond:/usr/obj/usr/src/sys/VAGABOND  i386
> 
> I loose connectivity on our campus network, and cannot get it back.
> Here are relevant lines in my ~/.wpaconf file :
...

Can you check if you have r1.39 of sys/net80211/ieee80211_proto.c and if
not then try again with a fresh kernel. This may have been fixed around
the same time as you upgraded.


cheers,
Andrew


More information about the freebsd-current mailing list