Intel 965 and AGP

Tim Bishop tim at bishnet.net
Fri Jun 15 10:56:28 UTC 2007


On Thu, 2007-06-14 at 23:59 -0500, Novembre wrote:
> Hello,
> 
> Is Intel G965 supported on -CURRENT? It seems that the chipset cannot be
> detected as AGP by the kernel module 'agp' (it is a PCI Express chip in
> reality, as far as I know), so 'i915' and 'drm' modules cannot be loaded,
> and the X.org driver for i810 cannot be used to start X.
> Previously, I had 6.2-RELEASE installed, and that did not support the
> chipset (no agpgart device in /dev/, no 'agp' kernel module loaded). I tried
> updating some source files (agp.c, agp_intel.c, agp_i810.c, agpreg.h) using
> the -CURRENT sources and patching agp.c and agpreg.h with Eric Anholt's
> submitted patch ( see
> http://docs.freebsd.org/cgi/mid.cgi?1177096992.5641.11.camel ), but that
> didn't work as well; no matter what I tried with 6.2-RELEASE, no agp device
> was detected. Then I erased my -RELEASE install and tried -STABLE with the
> same results - no agp present. So I tried installing 7.0-CURRENT (though I
> could not install it, but that's another issue). Looking at the output of
> the system while booting, it was the only time that instead of
> ----------
> pci0: <display, VGA> at device 2.0 (no driver attached)
> ----------
> I did get something else (sorry, I don't remember the exact output now, but
> 'no driver attached' was not there and some hex address was present). Then I
> tried loading the 'i915' and 'drm' modules at the loader prompt, and 'drm'
> said something along the lines of 'no agp device present' (again, i don't
> remember the exact message), so it did not load. This is all before
> installing the 7.0-CURRENT (which I could not do), so maybe if I use Eric
> Anholt's patch for agp.c, it'll work.

That patch hasn't been committed as far as I know. I have that chipset
working on 7.0-CURRENT with the AGP patch and XOrg 7.2.

Tim.



More information about the freebsd-current mailing list