fdc0 doesn't attach on my current machine

Norikatsu Shigemura nork at FreeBSD.org
Thu Jun 14 15:56:55 UTC 2007


	I didn't notice this issue until now.  So I don't know when this
	issue started.  The issue is that I can't attach floppy disk
	drive.  I doesn't disable FDC on BIOS, and I can boot from
	floppy disk.  What should I do? 

# kldload fdc
fdc0: <Enhanced floppy controller> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: [FILTER]
device_attach: fdc0 attach returned 12
fdc1: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc1: [FILTER]
device_attach: fdc1 attach returned 12

# uname -a
FreeBSD nadesico.ninth-nine.com 7.0-CURRENT FreeBSD 7.0-CURRENT #61: Thu Jun 14 14:39:24 JST 2007     nork at nadesico.ninth-nine.com:/usr/obj/usr/src/sys/NADESICO  i386

# dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-CURRENT #61: Thu Jun 14 14:39:24 JST 2007
    nork at nadesico.ninth-nine.com:/usr/obj/usr/src/sys/NADESICO
acpi_alloc_wakeup_handler: can't alloc wake memory
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) III CPU family      1133MHz (1188.97-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6b1  Stepping = 1
  Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 2147418112 (2047 MB)
avail memory = 2095558656 (1998 MB)
ACPI APIC Table: <VIA694 AWRDACPI>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
smbios0: <System Management BIOS> at iomem 0xf13e0-0xf13fe on motherboard
smbios0: Version: 2.3, BCD Revision: 2.3
cryptosoft0: <software crypto> on motherboard
acpi0: <VIA694 AWRDACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of f0000, 4000 (3) failed
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 7fef0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff,0x4000-0x407f,0x4080-0x40ff,0x5000-0x500f on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8633 (Pro 266) host to PCI bridge> on hostb0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x9000-0x90ff mem 0xd0000000-0xdfffffff,0xf9000000-0xf900ffff irq 16 at device 0.0 on pci1
vgapci1: <VGA-compatible display> mem 0xe0000000-0xefffffff,0xf9010000-0xf901ffff at device 0.1 on pci1
uhci0: <VIA 83C572 USB controller> port 0xa000-0xa01f irq 17 at device 7.0 on pci0
uhci0: [GIANT-LOCKED]
uhci0: [ITHREAD]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xa400-0xa41f irq 18 at device 7.1 on pci0
uhci1: [GIANT-LOCKED]
uhci1: [ITHREAD]
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xfb117000-0xfb1170ff irq 19 at device 7.2 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb2: EHCI version 1.0
usb2: companion controllers, 2 ports each: usb0 usb1
usb2: <VIA VT6202 USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: <VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb2
uhub2: 4 ports with 4 removable, self powered
pcm0: <ESS Technology Maestro3> port 0xa800-0xa8ff mem 0xfb112000-0xfb113fff irq 18 at device 8.0 on pci0
pcm0: [ITHREAD]
pcm0: <SigmaTel STAC9744/45 AC97 Codec>
fwohci0: <Texas Instruments TSB82AA2> mem 0xfb115000-0xfb1157ff,0xfb108000-0xfb10bfff irq 19 at device 9.0 on pci0
fwohci0: [FILTER]
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 01:d2:00:00:04:23:01:b4
fwohci0: invalid speed 7 (fixed to 3).
fwohci0: Phy 1394a available S800, 3 ports.
fwohci0: Link S800, max_rec 4096 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:d2:00:23:01:b4
fwe0: Ethernet address: 02:d2:00:23:01:b4
sbp0: <SBP-2/SCSI over FireWire> on firewire0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x48000
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0x8800ffc0, gen=1, non CYCLEMASTER mode
hifn0 mem 0xfb114000-0xfb114fff,0xfb10e000-0xfb10ffff,0xfb100000-0xfb107fff irq 16 at device 10.0 on pci0
hifn0: [ITHREAD]
hifn0: Hifn 7955, rev 0, 32KB dram, pll=0x801<ext clk, 4x mult>
sym0: <1010-33> port 0xac00-0xacff mem 0xfb119000-0xfb1193ff,0xfb10c000-0xfb10dfff irq 17 at device 11.0 on pci0
sym0: Symbios NVRAM, ID 7, Fast-80, LVD, parity checking
sym0: open drain IRQ line driver, using on-chip SRAM
sym0: using LOAD/STORE-based firmware.
sym0: handling phase mismatch from SCRIPTS.
sym0: SCAN AT BOOT disabled for targets 0 1 2 3 4 5 6 8 9 10 11 12 13 14 15.
sym0: SCAN FOR LUNS disabled for targets 0 1 2 3 4 5 6 8 9 10 11 12 13 14 15.
sym0: [GIANT-LOCKED]
sym0: [ITHREAD]
sym1: <1010-33> port 0xb000-0xb0ff mem 0xfb116000-0xfb1163ff,0xfb110000-0xfb111fff irq 17 at device 11.1 on pci0
sym1: Symbios NVRAM, ID 7, Fast-80, SE, parity checking
sym1: open drain IRQ line driver, using on-chip SRAM
sym1: using LOAD/STORE-based firmware.
sym1: handling phase mismatch from SCRIPTS.
sym1: SCAN AT BOOT disabled for targets 1 2 3 4 5 6 8 9 10 11 12 13 14 15.
sym1: SCAN FOR LUNS disabled for targets 0 1 2 3 4 5 6 8 9 10 11 12 13 14 15.
sym1: [GIANT-LOCKED]
sym1: [ITHREAD]
pci0: <network, ethernet> at device 13.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8233 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xb800-0xb80f at device 17.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
uhci2: <VIA 83C572 USB controller> port 0xbc00-0xbc1f irq 10 at device 17.2 on pci0
uhci2: [GIANT-LOCKED]
uhci2: [ITHREAD]
usb3: <VIA 83C572 USB controller> on uhci2
usb3: USB revision 1.0
uhub3: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
uhci3: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 10 at device 17.3 on pci0
uhci3: [GIANT-LOCKED]
uhci3: [ITHREAD]
usb4: <VIA 83C572 USB controller> on uhci3
usb4: USB revision 1.0
uhub4: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb4
uhub4: 2 ports with 2 removable, self powered
uhci4: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 10 at device 17.4 on pci0
uhci4: [GIANT-LOCKED]
uhci4: [ITHREAD]
usb5: <VIA 83C572 USB controller> on uhci4
usb5: USB revision 1.0
uhub5: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb5
uhub5: 2 ports with 2 removable, self powered
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xd0000-0xd3fff pnpid ORM0000 on isa0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
ums0: <Logitech USB Mouse, class 0/0, rev 1.10/6.20, addr 2> on uhub3
ums0: 3 buttons and Z dir.
WARNING: ZFS is considered to be an experimental feature in FreeBSD.
Timecounters tick every 1.000 msec
firewire0: 3 nodes, maxhop <= 2, cable IRM = 2
ZFS filesystem version 6
ZFS storage pool version 6
ad0: 78533MB <HDS728080PLAT20 PF2OA21B> at ata0-master UDMA100
ad1: 238475MB <I-O DATA NAKA-HDRM 2.10.8> at ata1-master UDMA100
(noperiph:sym0:0:-1:-1): SCSI BUS reset delivered.
(noperiph:sym1:0:-1:-1): SCSI BUS reset delivered.
fwohci0: txd err= 3 miss Ack err
firewire0: New S400 device ID:00110600000039bd
fwohci0: txd err= 3 miss Ack err
fwohci0: txd err= 3 miss Ack err
GEOM_LABEL: Label for provider ad1 is ufs/HDS250G.
SMP: AP CPU #1 Launched!
da0 at sym1 bus 0 target 0 lun 0
da0: <IBM DNES-318350W SA30> Fixed Direct Access SCSI-3 device 
da0: 40.000MB/s transfers (20.000MHz, offset 31, 16bit)
da0: Command Queueing Enabled
da0: 17501MB (35843670 512 byte sectors: 255H 63S/T 2231C)
Trying to mount root from ufs:/dev/ad0s1a
tap0: Ethernet address: 00:bd:ae:31:00:00
tap1: Ethernet address: 00:bd:b4:31:00:01
tap2: Ethernet address: 00:bd:b7:31:00:02
drm0: <ATI Radeon AP 9600> on vgapci0
info: [drm] AGP at 0xf0000000 128MB
info: [drm] Initialized radeon 1.25.0 20060524
info: [drm] Setting GART location based on new memory map
info: [drm] Loading R300 Microcode
info: [drm] writeback test succeeded in 1 usecs
drm0: [ITHREAD]
pid 8570 (scim-helper-manager), uid 1001: exited on signal 11
fdc0: <Enhanced floppy controller> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: [FILTER]
device_attach: fdc0 attach returned 12
fdc1: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc1: [FILTER]
device_attach: fdc1 attach returned 12


More information about the freebsd-current mailing list