GVirstor Label problem on -CURRENT

Ivan Voras ivoras at fer.hr
Thu Apr 26 13:36:42 UTC 2007

Jason Hills wrote:
> I know it is plenty new code. But I am getting a problem:
> ./gvirstor label -v -s 2097152 myvol ad8s1d
> Total virtual chunks: 524288 (4 MB each), 2097152 MB total virtual size.
> Clearing metadata on ad3s1d.
> Writing allocation table to ad3s1d... (4 MB, 1 chunks)
> Tried to write 4194304, written 4294967295 (Operation not permitted)
> Error writing out allocation map!
> ad8s1d is unmounted; I tried newfs´ing it but the problem remains;

A possible reason could be that the virstor map is larger than your 
physical storage (I think I don't have a check for this in the code 
[yet]). How large is ad3s1d?

I'll notify you and the list when I modify the code.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 249 bytes
Desc: OpenPGP digital signature
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20070426/5df4198a/signature.pgp

More information about the freebsd-current mailing list