zfs lor, panic

Kris Kennaway kris at obsecurity.org
Thu Apr 26 00:13:38 UTC 2007

On Wed, Apr 25, 2007 at 11:54:51PM +0200, Axel Scheepers wrote:
> Hello current list,
> I've just installed -current on my amd64(smp) workstation and tried zfs 
> a bit. I've setup my ports and src dir as gzip compressed zfs mounts and 
> used it without any problems. Then I moved my homedir to zfs, and all 
> went fine for a while.. until.. I tried to use rtorrent on a zfs volume. 
> Suddenly zfs would take all vm.kmem_size and eventually paniced as 
> described on this list before. I've set it to 512MB in /boot/loader.conf 
> and restricted the ARC to 64MB+1, this didn't panic but gave my a lock 
> order reversal and a system which completely spents it's time in system 
> time (according to top 100% with 640MB kmem) slowing it down to nearly a 
> halt.

If you are concerned about performance then turn off the enormously
expensive debugging options like WITNESS ;)

This LOR has been reported before, BTW.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20070426/91809191/attachment.pgp

More information about the freebsd-current mailing list