200704/amd64 CURRENT on da SunFire x4100

Eric Anderson anderson at freebsd.org
Thu Apr 19 12:59:45 UTC 2007

On 04/19/07 04:28, Mars G. Miro wrote:
> Greetings,
>   I happen to have a SunFire x4100 box (firmware of da BIOS, LSI/MPT,
> ILO is da latest) so I tested 200704/amd64 CURRENT on it. (Take note
> that FreeBSD 6.2 {amd64, i386} work fine on it, no issues whatsoever).
> Issues I encountered w/ CURRENT:
>  1) USB keyboard doesnt work (this has no PS/2). Even setting
> hint.atkbd.0.disabled="1" doesnt help. In order to install CURRENT, I
> had to boot to 6.2 and goto Fixit mode, manually dd'd, fdisk'd,
> bsdlabel'd and newfs'd da SAS HD, then temporarily brought up da em
> interface, mount the 200704 ISO (from an NFS  share) and manually
> installed whatever's needed at 7.0-CURRENT-200704/* to da HD, put in
> da necessary rc.conf/fstab/hosts/ttys(so i could manage via serial)
> files and voila, got it to boot (*finally*)

For reference, I have several Dell PowerEdge 1950's that do not have 
working USB in -CURRENT (but work in 6-STABLE) (AMD64), and also a Dell 
Precision 390 with the same issue.

Using the new usb stack worked, but my systems kept crashing (locking 
up, not able to get crash dumps).  I just cvsup'ed, still not working.

Either the new USB stack needs to get ironed and go in the tree, or 
newer hardware needs to be fixed on -CURRENT.

Anyone have any ideas what to look at to fix this?


More information about the freebsd-current mailing list