ZFS: amd64, devd, root file system.

Pawel Jakub Dawidek pjd at FreeBSD.org
Sat Apr 14 10:23:36 UTC 2007

On Sat, Apr 14, 2007 at 11:21:37AM +0200, Stefan Esser wrote:
> Pawel Jakub Dawidek wrote:
> > On Mon, Apr 09, 2007 at 03:17:23AM +0200, Pawel Jakub Dawidek wrote:
> Hi Pawel,
> great to see ZFS support committed to -current!
> It is amazingly simple to get a test setup going and it worked fine
> in my initial simple test cases. But now I've run into problems that
> probably are not technical but caused by a lack of understanding ...

This is not the first report that it doesn't work as it should. One was
that /boot/defaults/loader.conf wasn't fresh enough, and there were no:


lines at the end. Can you verify you have them?

Can you send me log of full boot process?

> Hmmm, there are a few points that I do not fully understand:
> It seems that ZFS "legacy" mounts are not supported under FreeBSD,
> is this correct? (E.g. if I enter "zfs set mountpoint=legacy test"
> then "test" can not be mounted with "zfs mount test" and there is
> no other way to mount it since we do not have a "mount_zfs", yet?)

They are supported. "legacy" means that you no longer use 'zfs mount' to
mount them, but simply mount(8) (or /etc/fstab). There is no mount_zfs
and there won't be one, because we are moving away from such commands.
You should use 'mount -t zfs' instead.

> I tried to set the mountpoint of my to-be root file system to "/"
> with "zfs set mountpoint=/ test" but I'm under the impression that
> this does not really work. Setting it to "//" does appear to have
> the desired effect, though, but may lead to a panic during shutdown.
> (Sorry, I've got no core-dumps but could try producing one later
> if there is interest. The panic is because of a ref count becoming
> negative but I did not write down the message.)

The mount point can be set to whatever you like, but you can still mount
it using different mount point by hand (via mount(8)).
The most proper way is probably to set mountpoint to "legacy".

> I decided to have multiple zfs file systems (test/var, test/usr ...)
> and can see them with zfs list. What is the correct way to get them
> mounted automatically? (Assuming I get the problem to have the kernel
> automatically mount the ZFS root solved ...)

zfs_enable="YES" in your /etc/rc.conf.

> Do I need fstab entries for for ZFS file systems (e.g. "test/usr")
> or does ZFS mount them automatically when the pool "test" is mounted?

They are mount via rc.d/zfs script.

> Or do I need a fstab line for each of them?
> What's supposed to go into /etc/zfs, besides the ZFS exports file?

For now only exports file. zpool.cache use to be there as well, but we
need it in /boot/zfs/ to be able to have root-on-ZFS.

Pawel Jakub Dawidek                       http://www.wheel.pl
pjd at FreeBSD.org                           http://www.FreeBSD.org
FreeBSD committer                         Am I Evil? Yes, I Am!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20070414/072bd20b/attachment.pgp

More information about the freebsd-current mailing list