Radeon 9550 + R300 DRM + Xorg 6.9 = freeze

Dejan Lesjak dejan.lesjak at ijs.si
Sat Jan 21 21:11:49 PST 2006

Nicolas Blais wrote:

> Not my lucky day :)
> After upgrading my Xorg port to 6.9.0, my -CURRENT freezes at launch of
> kdm. I'm able to do nothing with the system (can't exit to debugger, can't
> ssh to
> it).  Running top in another tty while loading X at the same time shows
> that Xorg uses 99.9% of WCPU.
> Checking around, I found that the actual freeze was due to Xorg using the
> R300 microcode (commenting out the Load "glx" and Load "dri" in xorg.conf
> makes X work again).
> I'm lost as to where to start debugging this as I cannot ssh,
> Ctrl-Alt-Backspace or get a dump during that freeze. Since it causes a
> crash, anything logged on the harddrive is lost (no sync done...)
> I tried running xorgcfg (graphic mode) to see if it would record something
> useful in Xorg.8.log and I have it attached. For some reason, X detects my
> lcd as having a max res of 1280x1024, but tries to open a display for
> 1600x1200 which only makes my screen show an "Out of Resolution" message.
> My console shows a message similar to "R300 Microcode loaded". I can
> Ctrl-Alt-Backspace out of X.
> I've tried both dri and dri-devel with no luck.
> So I resume:
>   1. Xorg 6.9.0 + R300 DRM + dri causes freeze
>   2. Disable dri+glx in Xorg.conf makes X work again (without drm)
>   3. xorgcfg tries to start in 1600x1200 for a screen capable of only
> 1280x1024, rendering it useless.
> Anyone using a R300 powered card (Radeon 9550/9600) with DRM+Xorg 6.9.0
> out there?
> dmesg:
> vgapci0: <VGA-compatible display> port 0xe000-0xe0ff mem
> 0xe8000000-0xefffffff,0xfbe00000-0xfbe0ffff irq 16 at device 0.0 on pci1
> drm0: <ATI Radeon AS 9600 AS> on vgapci0
> info: [drm] AGP at 0xe0000000 64MB
> info: [drm] Initialized radeon 1.19.0 20050911
> vgapci1: <VGA-compatible display> mem
> 0xf0000000-0xf7ffffff,0xfbf00000-0xfbf0ffff at device 0.1 on pci1

Somewhat like this:
http://lists.freedesktop.org/archives/xorg/2006-January/012303.html ?
You can try the mentioned patch by putting patch-radeon from here:
in x11-servers/xorg-server/files directory and reinstalling xorg-server


More information about the freebsd-current mailing list