System call munmap returning with the following locks held: Giant

Kris Kennaway kris at
Tue Jan 17 23:05:53 PST 2006

I ran some code of ups@ that essentially does mmap/munmap of created
files, which I ran on a nfs-mounted filesystem.  At the same time I
was running umount -f on that filesystem in a loop (this was all to
try and provoke another umount -f panic I'm seeing).  It quickly
panicked with this:

System call munmap returning with the following locks held:
exclusive sleep mutex Giant r = 0 (0xc07ea408) locked @ vm/vm_object.c:449
panic: witness_warn
cpuid = 1
KDB: enter: panic
[thread pid 3045 tid 100101 ]
Stopped at      kdb_enter+0x30: leave
db> wh
Tracing pid 3045 tid 100101 td 0xc9627000
kdb_enter(c071c7f5,1,c0720ca2,f7a46c64,c9627000) at kdb_enter+0x30
panic(c0720ca2,f7a46c8c,1,2,c9627000) at panic+0x13f
witness_warn(2,0,c073c410,c07214aa,c9922318) at witness_warn+0x16a
syscall(3b,3b,3b,2804ebb6,bfbfe8a8) at syscall+0x56d
Xint0x80_syscall() at Xint0x80_syscall+0x1f
--- syscall (0, FreeBSD ELF32, nosys), eip = 0x28127e7f, esp = 0xbfbfe7fc, ebp = 0xbfbfe828 ---

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list