dhclient ignoring link on wi0

Benjamin Close cisbjc at cs.unisa.edu.au
Mon Jan 2 16:45:19 PST 2006

David Gilbert wrote:

>I've got a laptop with the PC-CARD wi0 in it.  I've currently got
>"ifconfig_wi0="DHCP"" in the rc.conf file.  dhclient runs and
>everything is fine... until the association drops for a little bit.
>Then it looses the IP address and dhclient never relizes that it's
>associated again.  Very annoying.
>I thought the whole point was that dhclient was suppose to notice
>these events?
>Dhclient in this case never quits ... and ... as far as I can tell,
>never looks for an address again (athough I'm not going to wait a
>whole day for the dhcp lease to timeout).
>Has anyone looked into this?  This is on 6.0-p1.
I have a slightly different but some what related issue. I can't get an 
initial IP.
The ironic thing is sometimes I can, other times I can't. It seems to be 
related to whether the lease has expired on the server or not.
Commenting out line 274 in dhclient.c seems to fix the problem as a 
temporary solution, but it's not the correct fix.
There was one point after the dhcp import where things worked but it 
might have been luck.

I've been trying to trace this down for a while. I believe it's a bug in 
the wi code. Two Dissassociate events are sent to the 80211 state 
machine by dhclient and it gets put in the INIT state, later the card 
gets link and it puts the 80211 state machine in the RUN state, though 
it's an invalid state transition. I've tried forcing it to the ASSOC 
state first with minor luck but I've not yet been able to get it consistent.

I'll try and provide more concrete data tonight...


3D Research Associate / System Administrator     +61 8 8302 3669
School of Computer and Information Science       Room D1-07, ML Campus
University of South Australia                    Mawson Lakes Blvd.
Benjamin.Close at cs.unisa.edu.au                   South Australia, 5095
F00D C83D 5F7E 5561 DF91  B74D E602 CAA3 4842 B5B4

More information about the freebsd-current mailing list