ata0 going crazy after upgrading to 6.0B5

Mikhail Teterin mi+mx at aldan.algebra.com
Thu Sep 29 11:35:45 PDT 2005


This is another oddity, I'm observing after an upgrade from 5.4-BETA to 6.0-BETA5 last night.

There are not IDE devices in the machine at all and the IDE controllers are
disabled in the BIOS (or so the BIOS says).

However, at boot time I get:

	Interrupt storm detected on "irq14: ata0"; throttling interrupt source

and then the interrupts never cease, according to the 'systat -vm'
[...]
                                                          zfod   Interrupts
Proc:r  p  d  s  w    Csw  Trp  Sys  Int  Sof  Flt        cow   47073 total
           2 51     62373    5  65446796    3       48528 wire        1: atkb
                                                   134340 act         6: fdc0
26.9%Sys  50.0%Intr  0.0%User  0.0%Nice 23.1%Idl   230976 inact 46567 14: ata
|    |    |    |    |    |    |    |    |    |            cache     6 17: xl0
=============+++++++++++++++++++++++++              92008 free     82 18: ahc
                                                          daefr       19: uhc
Namei         Name-cache    Dir-cache                     prcfr   209 lapic0: ti
    Calls     hits    %     hits    %                     react   209 lapic1: ti
                                                          pdwake
[...]

This knocks out one of my two processors of course... Nothing like this ever
happened in the 5.4 times...

The machine is an older Dell workstation with 2 PentiumII Xeons in it.

The ACPI never worked right on it -- whenever I tried enabling ACPI in the
BIOS, the machine would hang on boot. This is still happening now with 6.0 --
the hang is right after reporting the amounts of real and available memory.

	-mi


More information about the freebsd-current mailing list