[SOLVED] Re: UDP multicast packets not seen on listening interface in BETA5

Josh Carroll josh.carroll at gmail.com
Thu Sep 29 22:07:55 PDT 2005

I'm sorry for so many replies to my own thread here, but I figured out
my problem. You guys were right, I was not properly joining the
multicast group. The packets were binding to my default IP instead of Doing the following with pf fixed it:

nat on $ext_if from any to ->

I don't really understand why this wasn't necessary in 5.4 and
previous 6.0 BETAs, but I'm glad it's working.

I tried changing the code from:

thishost.sin_addr.s_addr = INADDR_ANY;


inet_aton("", &local_addr);
server.sin_addr.s_addr = local_addr.s_addr;

Where is one of the aliased IPs on fxp0, but when I try to
run the code, I get "Permission denied" from sendto(), even with pf

Ideally, I'd like to update the code to search the local interfaces
with SIOCGIFCONF and use that IP (if available), but testing it with
my IP hard-coded doesn't seem to work.

But debugging my code is outside the scope of this mailing list. :)

Thanks for the help and getting me pointed in the right direction. I'm
ok with nat'ing the packets for now to make it work. I'll debug things
myself and see if I can't get it to use the right source address


More information about the freebsd-current mailing list