an(4) timeouts after a while?

Bruce A. Mah bmah at freebsd.org
Thu Sep 22 09:47:29 PDT 2005


If memory serves me right, Nate Lawson wrote:
> I use an Aironet 340 card in my laptop, running 7-current.  It will run 
> fine for 30-40 minutes and then suddenly timeout.  Ejecting and 
> reinserting fixes this.  It may only happen after a suspend/resume, even 
> if the suspend/resume was before the card was first inserted.

I've seen this on an Aironet 350, RELENG_6 from near the start of
September:

an0: <Cisco Systems 350 Series Wireless LAN Adapter> at port 0x100-0x13f
irq 11 function 0 config 5 on pccard1
an0: got RSSI <-> dBM map
an0: supported rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
an0: Ethernet address: 00:40:96:50:25:19
an0: [GIANT-LOCKED]

I've noticed this problem happens more at $ORKPLACE (which has a
somewhat quirky radio environment, where I keep getting disassociated
and reassociated to a couple of nearby APs) than at home (one AP).  Not
sure how significant that is.  I don't use suspend/resume on this
machine, which is a ThinkPad T21.

> Here's what I get on insertion:
> an0: <Cisco Systems 340 Series Wireless LAN Adapter> at port 
> 0x2000-0x203f irq 11 function 0 config 5 on pccard1
> an0: record length mismatch -- expected 192, got 200 for Rid ff00
> an0: got RSSI <-> dBM map
> an0: supported rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> an0: Ethernet address: 00:40:xxxxx
> an0: [GIANT-LOCKED]
> 
> When net connections start hanging, this is ifconfig:
> an0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>          inet6 fe80::xx:xx:xx:xx%an0 prefixlen 64 scopeid 0x4
>          inet 10.0.xx.xx netmask 0xffffff00 broadcast 10.0.xx.255
>          ether 00:40:xx:xx:xx:xx
>          media: IEEE 802.11 Wireless Ethernet autoselect
>          status: no carrier
>          ssid  1:myssid channel 6
>          stationname ""
>          authmode OPEN privacy ON deftxkey 1 txpowmax 0 rtsthreshold 0
>          roaming DEVICE
> 
> And dmesg says:
> an0: xmit failed
> an0: device timeout

I've seen this dmesg output at this point.  Not sure what ifconfig says
at the time.

> Then I eject the card:
> an0: RID access failed
> an0: RID access failed
> an0: detached
> cbb1: Bad Vcc requested
> Interrupt storm detected on "irq11: pcm0 cbb0+++"; throttling interrupt 
> source
> cbb1: Bad Vcc requested

I get the first three lines but not the cbb1 / Interrupt storm messages.

> And then reinsert:
> an0: <Cisco Systems 340 Series Wireless LAN Adapter> at port 
> 0x2000-0x203f irq 11 function 0 config 5 on pccard1
> an0: record length mismatch -- expected 192, got 200 for Rid ff00
> an0: got RSSI <-> dBM map
> an0: supported rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> an0: Ethernet address: 00:40:xxxxx
> an0: [GIANT-LOCKED]

Bruce.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050922/3157a105/attachment.bin


More information about the freebsd-current mailing list