FreeBSD6.0 and VMWare 5.0.. No go

Matt Kosht matt.kosht at
Sat Sep 10 10:23:39 PDT 2005

On 9/10/05, Gleb Kozyrev <gkozyrev at> wrote:
> At loader set hint.apic.0.disabled=1

That worked thanks!

> But it won't help you because 6.0 can't see the virtual disk.
> After I boot from install CD the SCSI controller is recognized
> (bt0 for vmxbuslogic or mpt0 for vmxlsilogic) but no HDD is found.
> If I go to FixIt shell and issue an
> camcontrol devlist -v
> I see that the HDD is there with no device node assigned to it.
> After I do
> camcontrol rescan 0:0:0
> The drive is found and maybe setup could partition it, though I
> didn't try because after reboot the disk won't be seen anyway.
> 5.4 sees the disk on vmxlsilogic controller but shows lots
> of SCSI errors on console while working.

I read this thread. Not familiar enough with VMWare yet to know
where/what this config file is, but I'll give it a whirl.  Sounds like
it worked for 5.2.1 and 5.3 (which I couldn't get to work either)

> It seems that only 4.x can be run on ESX and they aren't going
> to support any newver versions.
:( Maybe if we all complained/offered help to debug issue to VMWare
about this they would fix it.   They only officially support 4.9 as a
guest running on ESX.

More information about the freebsd-current mailing list