libmap.conf firefox flash

Scott Robbins scottro at nyc.rr.com
Thu Sep 8 06:33:21 PDT 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thu, Sep 08, 2005 at 04:46:08PM +0400, Vladimir Grebenschikov wrote:
> В ср, 07/09/2005 в 21:49 -0800, Beecher Rintoul пишет:



> Firefox has a double free problem wih Flash7.  So I don't
> support it.  Please don't send me a report about firefox.
> Of course, I always welcome to recieve fixed problems report.
> 
> Please get and apply a dlsym(3) hook patch.
>         http://people.FreeBSD.org/~nork/rtld_dlsym_hack.diff
> This provides _dlsym(3) function to fix dynamic-link
> error "can't find gtk_major_version" ad-hoc-ly.
> 
> I don't set default to use flash7.  Please set-up your
> enviroment(ln -s, apply patch to rtld,...).


Last night, I posted that the configuration for Flash7 with CURRENT that
someone kindly posted worked for me with CURRENT, but not for 6.0BETA.

This morning on my workstation at work, I tried again, just using the
default libmap.conf from linuxpluginwrapper's /usr/share/examples.

I cd'd to /usr/X11R6/lib/browser_plugins (heh, that's much easier to do,
with tab completion, than to type) removed the symlinks pointing to
/usr/X11R6/lib/linux-flashplugin6, replaced them with symlinks to
linux-flashplugin7, and simply changed the 6's in my default libmap.conf
to 7.

In other words, again, I used the default example installed by
linuxpluginwrapper.  The default reads



 Flash6 with Mozilla/Firebird/Galeon/Epiphany/Konqueror
[/usr/X11R6/lib/linux-flashplugin6/libflashplayer.so]
libpthread.so.0			pluginwrapper/flash6.so
libdl.so.2			pluginwrapper/flash6.so
libz.so.1			libz.so.2
libstdc++-libc6.2-2.so.3	libstdc++.so.4
libm.so.6			libm.so.2
libc.so.6			pluginwrapper/flash6.so


I changed that to

# Flash7 with Mozilla/Firebird/Galeon/Epiphany/Konqueror
[/usr/X11R6/lib/linux-flashplugin7/libflashplayer.so]
libpthread.so.0			 pluginwrapper/flash6.so
libdl.so.2			pluginwrapper/flash7.so
libz.so.1			libz.so.2
libstdc++-libc6.2-2.so.3	libstdc++.so.4
libm.so.6			libm.so.3
libc.so.6			pluginwrapper/flash7.so


This got flash7 working on my 6.0BETA4 box with firefox. 

Thanks again to the person who posted his libmap.conf for CURRENT which
made me want to get flash7 working.  

Flash7 still freezes on some sites with native firefox, but works a
treat with linux-firefox (again, I installed that one from source, not
ports--I think it was Martin C. who inspired me to do that, so if he's
on this list, thanks)


- -- 

Scott

GPG KeyID EB3467D6
( 1B848 077D 66F6 9DB0 FDC2  A409 FA54 D575 EB34 67D6)
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Buffy: I don't wanna' bug Giles. He's still kinda' twitchy
when it comes to the subject of Angel.

Xander: Oh, it must be that whole 'Angel killed his girlfriend and
tortured him' thing, and Giles is petty when it comes to stuff like
that.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (FreeBSD)

iD8DBQFDID2e+lTVdes0Z9YRAnMBAJ9pzP14piu0JMFzRM2KYW+R+TaWdACePjJ0
EgxYIIYJf6J/+Ccv0iMeEsU=
=A8tI
-----END PGP SIGNATURE-----


More information about the freebsd-current mailing list