[6.0 beta3] problem with cvsup and wifi (iwi)

Stefan Ehmann shoesoft at gmx.net
Mon Sep 5 02:17:00 PDT 2005


On Sun, 2005-09-04 at 21:42 -0700, Darren Pilgrim wrote:
> > From: Pascal Hofstee [mailto:caelian at gmail.com] 
> > 
> > On Sun, 2005-09-04 at 18:07 -0700, Darren Pilgrim wrote:
> > > There is an issue with either the iwi driver or Damien Bergamini's 
> > > firmware that result in the device crashing and/or losing 
> > the network 
> > > under heavy packet load.  I'm having the same issue here with the 
> > > 2915. I can trigger it using cvsup or SSH-forwarded X sessions.
> > 
> > i am not exactly knowlegable on the matter .. but considering 
> > i experience the same cvsup behavior on my if_ral interface 
> > .. i am more inclined to believe it's an issue somewhere in 
> > the underlying framework than it is in a specific driver.
> 
> Except that it doesn't happen when I use my ath card.  If it is the
> framework, I'd be more inclined toward it being the result of iwi, iwp
> and ral being newer, externally maintained and less tightly integrated
> with net80211.
> 
> I seem to recall Sam Leffler saying something to the effect that Damien
> Bergamini hasn't kept up with the moving target of that Sam's work on
> net80211.

Sounds reasonable. When it was originally imported, I didn't have any
issues with cvsup.

Those problems started some time ago. Except for cvsup it works pretty
fine though. (I also get strange NFS error messages sometimes, but
haven't tested if they only happen with if_iwi).



More information about the freebsd-current mailing list