Poor Samba throughput on 6.0 RC1

Joao Barros joao.barros at gmail.com
Mon Oct 24 15:18:53 PDT 2005

I've this PIII 733MHz running 6.0 RC1 with a GENERIC kernel which I
can only squeeze out 5.5MB/s via a Samba share, reading or writing.
The share was from a RAID 5 volume and to eliminate possibilities, I
tried adding an IDE drive having the same results.
SCP throughput is about 1MB/s
I tried adding this to Samba configuration resulting in no improvement.
top and systat show nothing more than a 0.2 load with a 70% idle cpu
when doing a file copy at about 5MB/s

Strangely, the IDE, the boot disk which is a 9GB SCSI-2 and the RAID 5
volume all give about the same speed with a simple dd speed test:

AMR# dd bs=1M if=/dev/amrd0 of=/dev/null count=1000
1000+0 records in
1000+0 records out
1048576000 bytes transferred in 36.400622 secs (28806541 bytes/sec)
AMR# dd bs=1M if=/dev/ad0 of=/dev/null count=1000
1000+0 records in
1000+0 records out
1048576000 bytes transferred in 35.180386 secs (29805699 bytes/sec)
AMR# dd bs=1M if=/dev/da0 of=/dev/null count=1000
1000+0 records in
1000+0 records out
1048576000 bytes transferred in 37.693338 secs (27818603 bytes/sec)

This machine should be able to max out the network interface. What can
I check to find out the limiting factor?


Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 6.0-RC1 #7: Sat Oct 22 18:41:56 WEST 2005
    root at AMR.bsdtech.org:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III (735.00-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x683  Stepping = 3
real memory  = 267255808 (254 MB)
avail memory = 252051456 (240 MB)
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: < INTEL SOLANO70> on motherboard
acpi0: Power Button (fixed)
pci_link0: <ACPI PCI Link LNKA> irq 11 on acpi0
pci_link1: <ACPI PCI Link LNKB> irq 5 on acpi0
pci_link2: <ACPI PCI Link LNKC> irq 10 on acpi0
pci_link3: <ACPI PCI Link LNKD> irq 3 on acpi0
pci_link4: <ACPI PCI Link LNKE> on acpi0
pci_link5: <ACPI PCI Link LNKF> on acpi0
pci_link6: <ACPI PCI Link LNKG> on acpi0
pci_link7: <ACPI PCI Link LNKH> irq 15 on acpi0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82815 (i815 GMCH) SVGA controller> mem
0xf8000000-0xfbffffff,0xffa80000-0xffafffff irq 11 at device 2.0 on
pcib1: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci_link2: BIOS IRQ 11 does not match initial IRQ 10
pci1: <ACPI PCI bus> on pcib1
pcib2: <PCI-PCI bridge> at device 2.0 on pci1
pci2: <PCI bus> on pcib2
pcib3: <PCI-PCI bridge> at device 0.0 on pci2
pci3: <PCI bus> on pcib3
amr0: <LSILogic MegaRAID 1.51> mem 0xf0000000-0xf3ffffff irq 11 at
device 0.0 on pci3
amr0: <LSILogic PERC 3/DC> Firmware 198U, BIOS 3.35, 64MB RAM
pci2: <mass storage, SCSI> at device 1.0 (no driver attached)
fxp0: <Intel 82559 Pro/100 Ethernet> port 0xc800-0xc83f mem
0xff8fc000-0xff8fcfff,0xff600000-0xff6fffff irq 3 at device 3.0 on
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: Ethernet address: 00:30:48:11:2d:f5
fxp1: <Intel 82559 Pro/100 Ethernet> port 0xd000-0xd03f mem
0xff8fd000-0xff8fdfff,0xff700000-0xff7fffff irq 11 at device 4.0 on
miibus1: <MII bus> on fxp1
inphy1: <i82555 10/100 media interface> on miibus1
inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp1: Ethernet address: 00:30:48:11:2d:f4
ahc0: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xd400-0xd4ff mem
0xff8fe000-0xff8fefff irq 5 at device 5.0 on pci1
aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
ahc1: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xd800-0xd8ff mem
0xff8ff000-0xff8fffff irq 11 at device 5.1 on pci1
aic7899: Ultra160 Wide Channel B, SCSI Id=7, 32/253 SCBs
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH2 UDMA100 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
uhci0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> port
0xef40-0xef5f irq 3 at device 31.2 on pci0
usb0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
uhci1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> port
0xef80-0xef9f irq 15 at device 31.4 on pci0
usb1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
acpi_button0: <Sleep Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq
2 on acpi0
fdc0: [FAST]
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xc7fff on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 735004480 Hz quality 800
Timecounters tick every 1.000 msec
Waiting 5 seconds for SCSI devices to settle
ad0: 19073MB <Maxtor 32049H2 YAH814Y0> at ata0-master UDMA100
amrd0: <LSILogic MegaRAID logical drive> on amr0
amrd0: 104040MB (213073920 sectors) RAID 5 (optimal)
da0 at ahc0 bus 0 target 0 lun 0
da0: <WDIGTL WDE9150 ULTRA2 1.30> Fixed Direct Access SCSI-2 device
da0: 80.000MB/s transfers (40.000MHz, offset 31, 16bit)
da0: 8727MB (17873040 512 byte sectors: 255H 63S/T 1112C)
Trying to mount root from ufs:/dev/da0s1a
Joao Barros

More information about the freebsd-current mailing list