vgapci doesn't want to attach agp on ASUS M5A

Dmitry Pryanishnikov dmitry at
Sun Dec 25 04:29:04 PST 2005


  I've tried fresh (as of 24-Dec-2005) CURRENT on my ASUS M5A notebook
(based on Intel 915GM Express chipset), and got a problem with agp
module attachment. Here is the relevant part of pciconf -lv:

hostb0 at pci0:0:0:	class=0x060000 card=0x19971043 chip=0x25908086
 			rev=0x03 hdr=0x00
     vendor   = 'Intel Corporation'
     device   = '82915PM/GM/GMS, 82910GML Host Bridge'
     class    = bridge
     subclass = HOST-PCI

vgapci0 at pci0:2:0:	class=0x030000 card=0x18821043 chip=0x25928086
 			rev=0x03 hdr=0x00
     vendor   = 'Intel Corporation'
     device   = '82915GM/GMS, 82910GML Integrated Graphics Device'
     class    = display
     subclass = VGA

vgapci1 at pci0:2:1:	class=0x038000 card=0x18821043 chip=0x27928086
 			rev=0x03 hdr=0x00
     vendor   = 'Intel Corporation'
     device   = '82915GM/GMS,82910GML Mobile Express Family Graphics
 			Controller (??)'
     class    = display

I've tried both to compile devices agp,drm,i915 to the kernel and load them
via /boot/loader.conf - result with the stock kernel was the same:

vgapci0: <VGA-compatible display> port 0xec00-0xec07 mem
   0xfeb80000-0xfebfffff,0xd0000000-0xdfffffff,0xfeb40000-0xfeb7ffff irq 16
   at device 2.0 on pci0
drm0: <Intel i915GM> on vgapci0
error: [drm:pid0:drm_load] *ERROR* Card isn't AGP, or couldn't initialize AGP.
device_attach: drm0 attach returned 12

I had to hack /sys/dev/pci/vga_pci.c:

--- vga_pci.c.orig	Thu Dec 22 18:25:22 2005
+++ vga_pci.c	Sun Dec 25 13:04:09 2005
@@ -74,7 +74,7 @@
  	 * If AGP capabilities are present on this device, then create
  	 * an AGP child.
-	if (pci_find_extcap(dev, PCIY_AGP, NULL) == 0)
+//	if (pci_find_extcap(dev, PCIY_AGP, NULL) == 0)
  		device_add_child(dev, "agp", -1);

in order to get proper (I hope!) attachment of agp and drm:

vgapci0: <VGA-compatible display> port 0xec00-0xec07 mem
   0xfeb80000-0xfebfffff,0xd0000000-0xdfffffff,0xfeb40000-0xfeb7ffff irq 16
   at device 2.0 on pci0
agp0: <Intel 82915GM (915GM GMCH) SVGA controller> on vgapci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
drm0: <Intel i915GM> on vgapci0
info: [drm] AGP at 0xfeb80000 0MB
info: [drm] Initialized i915 1.2.0 20041217

Why doesn't vgapci want to attach an agp module on my notebook? What relevant
info should I dig further?

P.S. Here is my kernel config:

machine		i386
cpu		I686_CPU		# aka Pentium Pro(tm)
makeoptions	DEBUG=-g		#Build kernel with gdb(1) debug symbols
options 	INCLUDE_CONFIG_FILE     # Include this file in kernel
options 	SCHED_4BSD		# 4BSD scheduler
options 	PREEMPTION		# Enable kernel thread preemption
device		apic			# I/O apic
options 	INET			#Internet communications protocols
options 	FFS			#Fast filesystem
options 	UFS_ACL
options 	UFS_DIRHASH
options 	COMPAT_43
options 	SYSVSHM
options 	SYSVSEM
options 	SYSVMSG
options 	KDB
options 	KDB_TRACE
options 	DDB
options 	DDB_NUMSYM
options 	KTRACE			#kernel tracing
options 	P1003_1B_SEMAPHORES
device		pci
device		atkbdc		# AT keyboard controller
device		atkbd		# AT keyboard
device		psm		# PS/2 mouse
options 	KBD_INSTALL_CDEV	# install a CDEV entry in /dev
device		vga		# VGA video card driver
device		splash		# Splash screen and screen saver support
device		sc
options 	SC_HISTORY_SIZE=20000
device		ata
device		atadisk		# ATA disk drives
options 	ATA_STATIC_ID	# Static device numbering
device		scbus		# SCSI bus (required for SCSI)
device		da		# Direct Access (disks)
device		cd		# CD
device		pass		# Passthrough device (direct SCSI access)
device		pmtimer
device		loop		# Network loopback
device		ether		# Ethernet support
device		pty		# Pseudo-ttys (telnet etc)
device		md		# Memory "disks"
device		bpf		# Berkeley packet filter

Sincerely, Dmitry
Atlantis ISP, System Administrator
e-mail:  dmitry at
nic-hdl: LYNX-RIPE

More information about the freebsd-current mailing list