rebuild problems with ata-raid on array with freebsd native meta

Anton dci at kicks-ass.ru
Tue Dec 13 15:03:37 PST 2005


Hello freebsd-current,

      From the beginning...
      First of all i have a intel se7520jr2 motherboard with SATA RAID
      (or something:) integrated in ICH5R south bridge and two identical
      SATA HDDs connected to it. The aim is RAID1 array, which could be
      rebuilt without rebooting. Sounds simple.
      
      Before reading manuals and information i tried to do this
      directly, by creating RAID1 array in LSI Integrated RAID
      utility.
      FreeBSD6 had found created array and had been installed without
      any troubles, but `atacontrol rebuild ar0` always had had ENXIO
      as a result.
      After digging docs and ata-raid.c file, i understood, that
      arrays, which metadata format(LSI V3 MegaRAID) is r/o for
      ata-raid, can not be rebuilt by atacontrol(Is it correct?).
      
      Next step was disabling build-in 'RAID' and migrating to freebsd
      native metadata format.
      So, i had edited /etc/fstab to boot from ad0, then deleted array
      in LSI Utility, than disabled RAID extensions, than
      # atacontrol create RAID1 ad0 ad2
      # atacontrol detach ata1 && atacontrol attach ata1
      # atacontrol rebuild ar0
      than i had edited fstab back to boot from ar0, reboot(Will
      Robinson here),
      # atacontrol detach ata1 && atacontrol attach ata1
      # atacontrol rebuild ar0
      to sync discs again and here i'd got a subject problem.
      rebuild process started, dd spawned, after several seconds
      progress counter switched to 1%.
      but then ad2 became inactive(LED turned off), progress counter
      fall back to 0%. ad0 remains active at this time.
      hour later dd finished reading and exited, raid status remained
      "REBUILDING 0% completed", no errors on all terminals was shown.
      i tried to launch dd again, but it all remains the same(counter
      goes up to 1%, then ad2 deactivation and counter reset).

      so problem is here: if filesystems are mounted from ad0, i can
      rebuild array. if thay are mounted from ar0, rebuild process
      will fail after some progress.
      this doesn't depend on kernel(i tried to rebuild with GENERIC),
      on drives(i tried tree different HDDs as spare).
      metadata is in native format(FreeBSD PseudoRAID RAID1 on boot).

      here some info about filesystems configuration:

~ # cat /etc/fstab
# working config differs a lot, but error persists with this sample fstab.
# Device                Mountpoint      FStype  Options         Dump    Pass#
/dev/ar0s1b             none            swap    sw              0       0
/dev/ar0s1a             /               ufs     rw              1       1
/dev/ar0s1f             /home           ufs     rw              2       2
/dev/ar0s1d             /usr            ufs     rw              2       2
/dev/ar0s1e             /var            ufs     rw              2       2
~ # df -H
Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/ar0s1a    1.0G     57M    874M     6%    /
devfs          1.0k    1.0k      0B   100%    /dev
/dev/ar0s1f    281G     37k    259G     0%    /home
/dev/ar0s1d    1.0G    775M    156M    83%    /usr
/dev/ar0s1e    5.1G    999k    4.7G     0%    /var
~ #

      so where should i look at? maybe i must recreate slices after
      raid creation?
      or maybe LSI V3 metadata write support is coming soon(even simple,
      for single array) and i should just wait some time?

-- 
Best regards,
 Anton                          mailto:dci at kicks-ass.ru



More information about the freebsd-current mailing list