vmware calcru runtime went backward and huge inaccuracy in clock

Putinas Piliponis Putinas.Piliponis at hansa.lt
Mon Dec 5 22:52:26 PST 2005



I know I am not the first who brings up this problem. But browsing
trough mail archives I didn't found a working solution.

I am running vmware 5.5 currently and FreeBSD 6.0-RELEASE. After
upgrading from 5.4 (at the same time I upgraded vmware from 5.0 so can't
really say which fault is it).

I noticed what I don't get daily reports. After small investigation I
found out what clock inaccuracy is like in 2 minutes I get 1 minute time
delay from real clock.

(I wait 2 minutes, I do ntpdate with server, I get every time offset 60

I tried all kern.timecounter.hardware available options (ACPI-Fast,
i8254, TSC)

pretty much same result with all of them.


Time on host machine is accurate.

As well I have on other host (with same hardware) running VMware 5.0
with FreeBSD 5.4

with timecounter.hardware: ACPI-safe and time accuracy there is like 60s
in 24h (or normal in other words).



Soo.. here comes my question, is it vmware fault, or is it FreeBSD

And any suggestions what I can do about ?


More information about the freebsd-current mailing list