[rc update] sshd no longer starts at boot

Scott Robbins scottro at nyc.rr.com
Sun Dec 4 09:59:27 PST 2005

Hash: SHA1

On Sun, Dec 04, 2005 at 11:35:33AM -0500, Nicolas Blais wrote:
> On December 3, 2005 04:09 pm, Nicolas Blais wrote:
> > After a cvsup/buildworld today, sshd (and cupsd, reported in PR
> > ports/89892) will no longer start at boot on my system.
> > sshd_enable="YES" is still present in my /etc/rc.conf and yet it does not
> > start, nor does it seem like it even tried as there are no error messages:
> >

I'm finding sshd, cron, cups (there was a fix and an update
which I did for the port but it didn't help) aren't starting.  Postfix,
which I was starting, following the instructions in pkg_info, which
basically have you put "YES" for sendmail and no for a few other
sendmail things, also doesn't start.  I worked around that one by
using the second method in its pkg_info, marking sendmail="NO" and
symlinking /usr/local/sbin/postfix to /usr/local/etc/rc.d/postfix.sh

pf, jails, and ntpd work.  

With cron, pgrep crond gives a result, but there's no /var/run/cron.pid
(and cronjobs don't run) until it's manually started.

- -- 

Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Xander: Generally speaking, when scary things get scared, not 

Version: GnuPG v1.4.2 (FreeBSD)


More information about the freebsd-current mailing list