Brief Report: IBM/Lenovo z60t notebook with FreeBSD

Robert Watson rwatson at
Sat Dec 3 03:36:30 PST 2005

Last week, I ordered byself a new notebook -- for reasons of price, stock, 
features, etc, I went with the Lenovo z60t 2511.  This is IBM part number 
UM3EJUK, and comes with a 14" display (1280x768 widescreen), 1.86GHz 
Pentium M, 512M of memory, and a 60GB hard disk.  It also has hardware 
fingerprint scanner, bluetooth, SD card reader, broadcom gig-e, firewire, 
atheros 802.11 chipset, and various other neat things.  Obviously, I 
installed FreeBSD on it.  Throughout, I found the site useful.

After chatting with Bjoern Zeeb <bz>, I concluded that I would leave XP on 
the notebook, as well as the IBM maintenance partition.  The advantage to 
keeping these around is that it makes it possible to pick up useful things 
like BIOS updates, and possibly makes getting support easier when things 
go horribly wrong (hasn't happened yet).  I successfully booted the 6.0 
release CD and used the livecd along with ntfsprogs to resize the 
partition.  Suggestion: we should include the ntfsprogs package on the 
install CD, even if we don't provide any UI for it.  After a bit of 
cylinder math, I appear to have both reduced the ntfs partition to a much 
smaller size, and not corrupted it.  One annoying nit I ran into was that 
when fdisk complained about my not ending a slice on a cylinder boundary 
and offered to correct it for me, it rounded down rather than up: this is 
fine if you have nothing in the slice, but I think I'll be patching it to 
ask if you want to round down or up.

FreeBSD 6.0 installed without a hitch, and was up and running quickly. 
Immediately, I ran into two problems (with four parts):

(1) The current kernel AGP parts don't support the Intel 915gm chipset.
(2) 6.8.2 used the VESA video mode 1024x768.
(3) The committed i915 DRM parts don't work.
(4) When I loaded the if_ath driver to use the wireless, I got an NMI
     and panic.

Over the last two days, I've worked with Eric Anholt and Sam Leffler to 
try and track down the sources of these problems, and I'm pleased to 
report both are now resolved (when running with their patches).

In order to get the X11 bits working, I updated to 7-CURRENT, and applied 
a set of patches provided by Eric over the latest DRM drop he committed a 
few days ago.  I believe he has now committed those patches, and if not, 
will do so shortly.  I updated to xorg-server-snap, which provides the 7 release candidate server.  If you're reading this after 7 
comes out, I imagine it should "just work".  If it's in the next few 
weeks, make sure you're running 7-CURRENT and using the xorg-server-snap 
server -- you can use the rest of the 6.8.2 parts with this with no 
problem (libraries, clients, and so on).  If you're running 6.x and the 
above hasn't yet been MFC'd, you'll need to get patches for the backport 
of the AGP and DRM changes.  I'm pleased to report DRM also appeared to 
work fine with Eric's patches, and glxgears spins away happily.

I was able to get the atheros card working with the NDIS Project Evil 
magic.  You can find the AR5211.SYS and NET5211.INF files on the Windows 
partition (I mounted the partition using ntfs support in FreeBSD without a 
hitch to copy them over).  I had to tweak the INF file so that it could be 
parsed by ndisgen to comment out the following two lines:


However, I was unable to get the card to go into both 802.11b mode and ad 
hoc mode at the same time.  I need to send Bill Paul a useful report, 
although possibly once I'm back from travel.

After chatting with Sam Leffler, and being a bit puzzled about the exact 
failure mode I was seeing, we concluded I should apply his most recent 
atheros and 802.11 patches, and update to the latest HAL.  Once I did 
this, all was well.  I don't know what Sam's plans for merging these is, 
but they're what you need.  I did not try the new HAL with the old 802.11 
code and driver.

At the end of the day, I have most things working with this notebook 
except for the following:

- The Ricoh SD card reader is unsupported.  Google suggests that Linux
   also doesn't support it, and that although there's a reverse engineering
   effort going on, it has made limited progress.  They're looking for
   volunteers if anyone is interested in learning about reverse

- I don't yet have the sound driver attaching.  Not really something I
   know much about -- it could be an existing driver would work if I
   tweaked the PCI IDs, or not.  The card is described in pciconf -lv as
   "82801FB/FR/FW/FRW Intel High DefiNition Audio Controller", class
   0x040300, card 0x05b71014, chip 0x26688086, rev 0x03.

- The fingerprint scanner attaches as ugen0.  I haven't googled around yet
   to see what I can learn.

- Suspend/resume was pretty sad, I don't advise trying it.  I may get a
   chance to investigate this more while on travel over the next few weeks.

BTW, just so there's no confusion: the 14" version of this notebook is 
actually the 15" notebook but with a smaller panel.  The case is 
apparently identical, so if you buy the 14" one, make sure it's not under 
the assumption it will be smaller than the 15" one, because it won't be 

Robert N M Watson

More information about the freebsd-current mailing list