LSI Logic fibre channel adapter in FreeBSD 6.0-BETA3

Mischa Peters mischa.peters at gmail.com
Tue Aug 30 13:26:08 GMT 2005


On 8/29/05, Krzysztof Ciepłucha <kris at home.pl> wrote:
> Mischa Peters wrote:
> > Hi All,
> >
> > I am not sure if this is the correct list. But I have the following issue.
> >
> > I have a Fibre Channel card in my server, LSI Logic FC909A which was
> > working fine under FreeBSD 4.11 but is no longer working with
> > 6.0-BETA3. I have also tried it with BETA1 which also didn't work.
> >
> > The thing that I see in messages is:
> >
> > pci0: <serial bus, Fibre Channel> at device 11.0 (no driver attached)
> > pci0: <serial bus, Fibre Channel> at device 11.1 (no driver attached)
> >
> > I have seen that in GENERIC the old ncr drivers are disabled and are
> > replaced with sym.
> > Does this matter at all, or is this b0rken and does it needs fixing?
> 
> man mpt
> 
> HARDWARE
>       The following controllers are supported by the mpt driver:
> 
>       o   LSI Logic 53c1030 (Dual Ultra320 SCSI)
>       o   LSI Logic FC909 (1Gb/s Fibre Channel)
>       o   LSI Logic FC909A (Dual 1Gb/s Fibre Channel)
>       o   LSI Logic FC919 (2Gb/s Fibre Channel)
>       o   LSI Logic FC929, LSI Logic FC929X (Dual 2Gb/s Fibre Channel)
> 
> 

I have verified that this is indeed enabled in the kernel conf file.

device          mpt             # LSI-Logic MPT-Fusion

Anything else that I need to check?

Mischa


More information about the freebsd-current mailing list