FreeBSD-6-BETA3 broken with ports/audio/aureal-kmod; ports/graphics/linux_dri not working.

Mateusz Jędrasik imachine at toya.net.pl
Tue Aug 30 08:27:51 GMT 2005


Dnia poniedziałek, 29 sierpnia 2005 23:03, Ulrich Spoerlein napisał:
> On Sun, 28.08.2005 at 23:40:42 +0200, Mateusz J??drasik wrote:
> > The solution I would best see here is bumping
> > emulators/linux_base-suse-9.3 as default linux compat, updating the
> > unhappy ports to play nicely with such an upgrade, and using xorg-dri
> > drivers for linux_dri compatible with the xorg-libs avaliable with
> > emulators/linux_base-suse-9.3.
>
> I already did this locally, but it won't solve your problem. There is no
> binary r300 DRI driver in SuSE 9.3 and even compiling one on your own

I use r200 radeon cards, so that is not the issue, at least in my case 
locally; the issue is with the kernel module radeon.ko which is afaik no 
longer compatible with 4.3.0 drivers for dri from redhat8.

If you could whip up a patch of your local hacks, I guess they might be useful 
for any further work of people interested in bumping linux stuff and making 
it work alltogether with different linux_base settings.

> won't make it load, because you need to hack the DRI stuff so it will
> load the appropriate module (see pkg-descr of linux_dri).
>
> I already asked Eric for the patch, but it looks like he hasn't got it
> anymore.
>
> Ulrich Spoerlein

Cheers,

/m.
-- 
Mateusz Jędrasik


More information about the freebsd-current mailing list