Mergemaster issues in 5.4

Wouter Prins wouter at businessconnect.nl
Sun Aug 28 17:51:24 GMT 2005


Hello everyone,

I am having issues with running mergemaster on the following type of
system:

FreeBSD base.null0.nl 5.4-RELEASE-p6 FreeBSD 5.4-RELEASE-p6 #0: Sun Aug
28 15:10:22 CEST 2005     root at base.null0.nl:/usr/obj/usr/src/sys/BASE
i386

1.) I have installed this box from a mini-iso image and cvsup-ed ports and
src's.
2.) Created a custom kernel and installed it
3.) build and install of the world

When i want to run a mergemaster (although it isnt really needed in this
case) i am getting the following error:

--
cd /usr/src/etc; install -o root -g wheel -m 644  /var/tmp/temproot/etc/ssh
usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 file2
	              install [-bCcpSsv] [-B suffix] [-f flags] [-g
		      group] [-m mode]

*** Error code 64

Stop in /usr/src/etc.

*** FATAL ERROR: Cannot 'cd' to /usr/src/etc and install files to the temproot environment

--

It looks like mergemaster doesnt copy over the sourcefile for some
reason, i have tried to check the archives but couldnt find anyone with
the same issues.

I ignored the above message and stumbled upon the same error when i wanted to do a 'make
distribution DESTDIR=/j/1' to create a jail.

I have removed the world and sync-ed against another cvsup server but
still the same issues. Is there anything i am doing wrong?

If more info is needed please ask.

Kind regards,

Wouter Prins
-- 

QOTD:
	"Everything I am today I owe to people, whom it is now
	to late to punish."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050828/bfd9d43f/attachment.bin


More information about the freebsd-current mailing list