Trouble with 6 boot/loader: system resets

Stefan Bethke stb at lassitu.de
Sat Aug 27 19:54:24 GMT 2005


I'm trying to boot a Lex barebone (VIA Eden based) off a CF card that  
shows up as a ad3. So far, the box has been booting off a 2.5" disk.  
boot and loader are RELENG_6 from Thursday. A 5-stable dmesg is  
attached below.

When trying to boot off the CF, boot will load loader. Then the  
machine resets.

I've tried loading /boot/kernel/kernel directly. It appears to load  
the kernel, but then I get a BTX panic. (I currently don't have a  
serial console, but I could try to transcribe the output if that  
would help.)

How can I best debug this? Should I try earlier or later versions?

I'm a bit reluctant to update loader on the hard disk: if the update  
makes the system unbootable, I would lose my router...


Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights  
reserved.
FreeBSD 5.4-STABLE #2: Sat Jun  4 15:51:17 CEST 2005
     root at diesel.lassitu.de:/usr/obj/usr/src/sys/DIESEL
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: VIA C3 Samuel 2 (532.64-MHz 686-class CPU)
   Origin = "CentaurHauls"  Id = 0x673  Stepping = 3
   Features=0x803035<FPU,DE,TSC,MSR,MTRR,PGE,MMX>
real memory  = 528416768 (503 MB)
avail memory = 507424768 (483 MB)
acpi0: <VIA601 AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU (3 Cx states)> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0x6000-0x607f,0x5000-0x500f, 
0x4080-0x40ff,0x4000-0x407f,0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8601 (Apollo ProMedia/PLE133Ta) host to PCI bridge> mem  
0xe0000000-0xe3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C686B UDMA100 controller> port 0xc000-0xc00f, 
0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
uhci0: <VIA 83C572 USB controller> port 0xc400-0xc41f at device 7.2  
on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xc800-0xc81f at device 7.3  
on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <bridge> at device 7.4 (no driver attached)
pcm0: <VIA VT82C686A> port 0xd400-0xd403,0xd000-0xd003,0xcc00-0xccff  
irq 11 at device 7.5 on pci0
pcm0: <Avance Logic ALC200 AC97 Codec>
rl0: <RealTek 8139 10/100BaseTX> port 0xd800-0xd8ff mem  
0xe5810000-0xe58100ff irq 12 at device 8.0 on pci0
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:40:f4:67:ec:84
rl1: <RealTek 8139 10/100BaseTX> port 0xdc00-0xdcff mem  
0xe5811000-0xe58110ff irq 10 at device 9.0 on pci0
miibus1: <MII bus> on rl1
rlphy1: <RealTek internal media interface> on miibus1
rlphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl1: Ethernet address: 00:40:f4:67:ec:83
rl2: <RealTek 8139 10/100BaseTX> port 0xe000-0xe0ff mem  
0xe5812000-0xe58120ff irq 11 at device 11.0 on pci0
miibus2: <MII bus> on rl2
rlphy2: <RealTek internal media interface> on miibus2
rlphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl2: Ethernet address: 00:40:f4:67:ec:82
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10  
on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
npx0: <math processor> on motherboard
npx0: INT 16 interface
orm0: <ISA Option ROMs> at iomem 0xcc000-0xcffff,0xc0000-0xcbfff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on  
isa0
Timecounter "TSC" frequency 532640892 Hz quality 800
Timecounters tick every 10.000 msec
ipfw2 initialized, divert enabled, rule-based forwarding disabled,  
default to accept, logging disabled
ad2: 9590MB <IBM-DJSA-210/JS2AABAA> [19485/16/63] at ata1-master UDMA66
Mounting root from ufs:/dev/ad2s1a


-- 
Stefan Bethke <stb at lassitu.de>   Fon +49 170 346 0140






More information about the freebsd-current mailing list