iwi not roaming between access points

Adam McDougall mcdouga9 at egr.msu.edu
Sat Aug 27 02:45:39 GMT 2005


I recently obtained a new Dell Latitude D810 laptop with 
Intel(R) PRO/Wireless 2200BG.  It works reasonably well,
but at work we have approx. 90 access points on the same
ssid, and I cannot roam between them.  If I compile 
/usr/src/tools/tools/ath/80211debug to work with iwi0
rather than ath0 and run ./80211debug +dumppkts, I see
verification of my theory that it is only talking with
the access point it originally associated with.  I can
walk down the hallway until the signal vanishes past a
useful level (as indicated by the number after rssi until
no response), and by this I deduce that iwi0 is only talking
with the original access point.  At that point, if iwi0
shows it is still associated (but not working),
I can ifconfig iwi0 ssid "thessid" and iwi0 will rescan for
access points and start working.  However, if iwi0 shows 
no association, setting ssid does not work but doing an
ifconfig down/up revives it.  

By the time I walk out of range of the original access point,
I have walked past at least 2 other access points and closer
to a third.  If I take the stairs to another floor, it is 
a guaranteed dead association.  When I login to the wireless
equipment, I verify that my laptop is only associated with
the originally associated access point.  

The same card works fine in windows, but thats just for 
reference ;)

I am running 7.0-current last built on Aug 24, with 
iwi-firmware-2.3_1. 

Other wireless nics have worked fine for me in regards
to roaming, although I do have an ipw0 available for
testing that I have not tried roaming with if it would
be helpful.  I am very appreciative for the iwi driver
since it has been more stable than other 802.11g drivers
I have used in FreeBSD.  

Is there anything else I can try, or more details I can
provide to solve this issue?  Thanks.  


More information about the freebsd-current mailing list