Panic (nve) on install with 6.0-BETA3 ISO

Philip Murray pmurray at nevada.net.nz
Sat Aug 27 01:30:06 GMT 2005


Hi,

I was installing 6.0-BETA3 on an Nvidia nForce2 motherboard from FTP  
with the onboard nve adapter and got the following panic:

panic: nve_ifstart: attempted use of a free mbuf!
cpuid= 0
KDB: enter: panic
[thread pid 35 tid 100017 ]
Stopped at       kdb_enter+0x2b: nop
db> trace
Tracing pid 35 tid 100017 td 0xc1d4a900
kdb_enter(c08574d4) at kdb_enter+0x2b
panic(c082aefa,c081567c,c1eb250c,354,d8790740) at panic+0x127
nve_ifstart(c1eb2400) at nve_ifstart+0x35a
if_start(c1eb2400) at if_start+0x7b
ether_output_frame(c1eb2400,c1fe8e00,0,0,0) at ether_output_frame+0x1d9
ether_output(c1eb2400,c1fe8e00,c203d070,c2077bdc,c2066a00) at  
ether_output+0x3b4
ip_output(c1fe8e00,0,d3628ae0,0,0) at ip_output+0x6fc
tcp_ouput(c20e1ac8) at tcp_output+0xfb2
tcp_input(c1eb7b00,14,c1eb7b00,0,0) at tcp_input+0x13cc
ip_input(c1eb7b00) at ip_input+0x511
netisr_processqueue(c096ffd8) at netisr_processqueue+0x6e
swi_net(0) at swi_net+0xbe
ithread_loop(c1d94580,d3628d38,c1d94580,c061f924,0) at ithread_loop 
+0x11c
fork_exit(c061f924,c1d94580,d3628d38) at fork_exit+0xa0
fork_trampoline() at fork_trampoline+0x8
--- trap 0x1, eip = 0, esp = 0xd3628d6c, ebp = 0 ---
db>

I transcribed the backtrace by hand so please forgive any typos. I  
can reproduce this if there is any more information needed.  
Unfortunately as it's a fresh install I can't get a dump.

The nve interface is:

nve0: <NVIDIA nForce MCP2 Networking Adapter> port 0xd400-0xd407 mem  
0xe0005000-0xe0005ffff ird 20 at device 4.0 on pci0
nve0: Ethernet address 00:00:00:40:06:01
miibus0: <MII bus> on nve0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
nve0: Ethernet address: 00:00:00:40:06:01
nve0: [GIANT-LOCKED]


Cheers

Phil Murray




More information about the freebsd-current mailing list