FreeBSD/amd64 phobos.envescent.net 6.0-BETA2 - Possible SiI 3512 SATA-150 lockup/freezing bug

Alexander Chamandy bsdfreak at gmail.com
Wed Aug 10 23:38:33 GMT 2005


On 8/10/05, Alexander Chamandy <bsdfreak at gmail.com> wrote:
> I'm seeing messages like this on bootup: ata2: FAILURE - oversized DMA
> transfer attempt 8704 > 7680
> 
> I know FreeBSD has some issues with the SiI SATA controllers so I'm
> not sure if this is already known, but essentially under high load the
> machine either hardlocks or simply reboots.  I've tried custom and
> generic kernels as well as reinstalling to no avail.  This system,
> like the subject says, is running FreeBSD/amd64 6.0-BETA2.  Should I
> disable DMA?  Is there a workaround?  Dmesg from GENERIC kernel is as
> follows:
> 
> Copyright (c) 1992-2005 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>         The Regents of the University of California. All rights reserved.
> FreeBSD 6.0-BETA2 #0: Tue Aug  2 22:37:52 UTC 2005
>     root at portnoy.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
> WARNING: WITNESS option enabled, expect reduced performance.
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: AMD Athlon(tm) 64 Processor 3200+ (2080.20-MHz K8-class CPU)
>   Origin = "AuthenticAMD"  Id = 0xf48  Stepping = 8
>   Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
>   AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow+,3DNow>
> real memory  = 2147418112 (2047 MB)
> avail memory = 2062671872 (1967 MB)
> ACPI APIC Table: <Nvidia AWRDACPI>
> ioapic0 <Version 1.1> irqs 0-23 on motherboard
> acpi0: <Nvidia AWRDACPI> on motherboard
> acpi0: Power Button (fixed)
> pci_link0: <ACPI PCI Link LNK1> irq 3 on acpi0
> pci_link1: <ACPI PCI Link LNK2> irq 10 on acpi0
> pci_link2: <ACPI PCI Link LNK3> irq 11 on acpi0
> pci_link3: <ACPI PCI Link LNK4> on acpi0
> pci_link4: <ACPI PCI Link LNK5> irq 7 on acpi0
> pci_link5: <ACPI PCI Link LUBA> irq 4 on acpi0
> pci_link6: <ACPI PCI Link LUBB> irq 4 on acpi0
> pci_link7: <ACPI PCI Link LMAC> irq 5 on acpi0
> pci_link8: <ACPI PCI Link LAPU> on acpi0
> pci_link9: <ACPI PCI Link LACI> on acpi0
> pci_link10: <ACPI PCI Link LMCI> on acpi0
> pci_link11: <ACPI PCI Link LSMB> irq 5 on acpi0
> pci_link12: <ACPI PCI Link LUB2> irq 4 on acpi0
> pci_link13: <ACPI PCI Link LFIR> on acpi0
> pci_link14: <ACPI PCI Link L3CM> on acpi0
> pci_link15: <ACPI PCI Link LIDE> on acpi0
> pci_link16: <ACPI PCI Link LSID> on acpi0
> pci_link17: <ACPI PCI Link APC1> irq 16 on acpi0
> pci_link18: <ACPI PCI Link APC2> irq 17 on acpi0
> pci_link19: <ACPI PCI Link APC3> irq 18 on acpi0
> pci_link20: <ACPI PCI Link APC4> irq 19 on acpi0
> pci_link21: <ACPI PCI Link APC5> irq 16 on acpi0
> pci_link22: <ACPI PCI Link APCF> irq 0 on acpi0
> pci_link23: <ACPI PCI Link APCG> irq 0 on acpi0
> pci_link24: <ACPI PCI Link APCH> irq 0 on acpi0
> pci_link25: <ACPI PCI Link APCI> irq 0 on acpi0
> pci_link26: <ACPI PCI Link APCJ> irq 0 on acpi0
> pci_link27: <ACPI PCI Link APCK> irq 0 on acpi0
> pci_link28: <ACPI PCI Link APCS> irq 23 on acpi0
> pci_link29: <ACPI PCI Link APCL> irq 0 on acpi0
> pci_link30: <ACPI PCI Link APCM> irq 0 on acpi0
> pci_link31: <ACPI PCI Link AP3C> irq 0 on acpi0
> pci_link32: <ACPI PCI Link APCZ> irq 0 on acpi0
> pci_link33: <ACPI PCI Link APSI> irq 0 on acpi0
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
> cpu0: <ACPI CPU> on acpi0
> acpi_button0: <Power Button> on acpi0
> pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff,0xcf0-0xcf3 on acpi0
> pci0: <ACPI PCI bus> on pcib0
> pci_link22: Unable to choose an IRQ
> pci_link23: Unable to choose an IRQ
> pci_link29: Unable to choose an IRQ
> pci_link24: Unable to choose an IRQ
> agp0: <NVIDIA nForce3 AGP Controller> mem 0xe0000000-0xe7ffffff at
> device 0.0 on pci0
> isab0: <PCI-ISA bridge> at device 1.0 on pci0
> isa0: <ISA bus> on isab0
> pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
> ohci0: <nVidia nForce3 USB Controller> mem 0xfc002000-0xfc002fff irq
> 20 at device 2.0 on pci0
> ohci0: [GIANT-LOCKED]
> usb0: OHCI version 1.0, legacy support
> usb0: SMM does not respond, resetting
> usb0: <nVidia nForce3 USB Controller> on ohci0
> usb0: USB revision 1.0
> uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 3 ports with 3 removable, self powered
> ohci1: <nVidia nForce3 USB Controller> mem 0xfc003000-0xfc003fff irq
> 21 at device 2.1 on pci0
> ohci1: [GIANT-LOCKED]
> usb1: OHCI version 1.0, legacy support
> usb1: SMM does not respond, resetting
> usb1: <nVidia nForce3 USB Controller> on ohci1
> usb1: USB revision 1.0
> uhub1: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub1: 3 ports with 3 removable, self powered
> ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfc004000-0xfc0040ff
> irq 22 at device 2.2 on pci0
> ehci0: [GIANT-LOCKED]
> usb2: EHCI version 1.0
> usb2: companion controllers, 4 ports each: usb0 usb1
> usb2: <EHCI (generic) USB 2.0 controller> on ehci0
> usb2: USB revision 2.0
> uhub2: nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
> uhub2: 6 ports with 6 removable, self powered
> uhub3: vendor 0x0543 product 0x1167, class 9/0, rev 2.00/ff.ff, addr 2
> uhub3: multiple transaction translators
> uhub3: 4 ports with 4 removable, self powered
> ulpt0: HewLett Packard HP LaserJet 1200, rev 1.10/1.00, addr 3, iclass 7/1
> ulpt0: using bi-directional mode
> nve0: <NVIDIA nForce MCP3 Networking Adapter> port 0xd000-0xd007 mem
> 0xfc000000-0xfc000fff irq 20 at device 5.0 on pci0
> nve0: Ethernet address 00:0d:61:14:6f:39
> miibus0: <MII bus> on nve0
> rlphy0: <RTL8201L 10/100 media interface> on miibus0
> rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> nve0: Ethernet address: 00:0d:61:14:6f:39
> nve0: [GIANT-LOCKED]
> atapci0: <nVidia nForce3 UDMA133 controller> port
> 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 8.0 on
> pci0
> ata0: <ATA channel 0> on atapci0
> ata1: <ATA channel 1> on atapci0
> pcib1: <ACPI PCI-PCI bridge> at device 10.0 on pci0
> pci1: <ACPI PCI bus> on pcib1
> pci1: <multimedia, audio> at device 8.0 (no driver attached)
> pci1: <input device> at device 8.1 (no driver attached)
> fwohci0: <1394 Open Host Controller Interface> mem
> 0xfb005000-0xfb0057ff,0xfb000000-0xfb003fff irq 17 at device 8.2 on
> pci1
> fwohci0: OHCI version 1.10 (ROM=0)
> fwohci0: No. of Isochronous channels is 4.
> fwohci0: EUI64 00:02:3c:00:21:04:e6:cc
> fwohci0: Phy 1394a available S400, 2 ports.
> fwohci0: Link S400, max_rec 2048 bytes.
> firewire0: <IEEE1394(FireWire) bus> on fwohci0
> fwe0: <Ethernet over FireWire> on firewire0
> if_fwe0: Fake Ethernet address: 02:02:3c:04:e6:cc
> fwe0: Ethernet address: 02:02:3c:04:e6:cc
> fwe0: if_start running deferred for Giant
> sbp0: <SBP-2/SCSI over FireWire> on firewire0
> fwohci0: Initiate bus reset
> fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
> firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
> firewire0: bus manager 0 (me)
> ahc0: <Adaptec 2940 Ultra2 SCSI adapter> port 0xa800-0xa8ff mem
> 0xfb004000-0xfb004fff irq 18 at device 10.0 on pci1
> ahc0: [GIANT-LOCKED]
> aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs
> atapci1: <SiI 3512 SATA150 controller> port
> 0xac00-0xac07,0xb000-0xb003,0xb400-0xb407,0xb800-0xb803,0xbc00-0xbc0f
> mem 0xfb006000-0xfb0061ff irq 17 at device 13.0 on pci1
> ata2: <ATA channel 0> on atapci1
> ata3: <ATA channel 1> on atapci1
> pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
> pci2: <ACPI PCI bus> on pcib2
> pci2: <display, VGA> at device 0.0 (no driver attached)
> pci2: <display> at device 0.1 (no driver attached)
> fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
> fdc0: [FAST]
> atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
> atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> orm0: <ISA Option ROMs> at iomem
> 0xc0000-0xccfff,0xd0000-0xd7fff,0xd8000-0xdc7ff,0xdd000-0xe27ff on
> isa0
> ppc0: cannot reserve I/O port range
> sc0: <System console> at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0: port may not be enabled
> sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
> sio0: type 8250 or not responding
> sio1: configured irq 3 not in bitmap of probed irqs 0
> sio1: port may not be enabled
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
> ums0: Logitech USB-PS/2 Optical Mouse, rev 2.00/22.00, addr 2, iclass 3/1
> ums0: 7 buttons and Z dir.
> Timecounter "TSC" frequency 2080199228 Hz quality 800
> Timecounters tick every 1.000 msec
> Waiting 5 seconds for SCSI devices to settle
> acd0: DVDR <TEAC DV-W516GA/C4S2> at ata1-slave UDMA33
> ad4: 286188MB <Maxtor 6B300S0 BANC1B10> at ata2-master SATA150
> ata2: FAILURE - oversized DMA transfer attempt 8704 > 7680
> ad4: setting up DMA failed
> da0 at ahc0 bus 0 target 0 lun 0
> da0: <SEAGATE ST118273LW 6246> Fixed Direct Access SCSI-2 device
> da0: 80.000MB/s transfers (40.000MHz, offset 15, 16bit)
> da0: 17366MB (35566480 512 byte sectors: 255H 63S/T 2213C)
> ATA PseudoRAID loaded
> Trying to mount root from ufs:/dev/ad4s2a
> WARNING: / was not properly dismounted
> pcm0: <Creative Audigy (EMU10K2)> port 0xa000-0xa01f irq 16 at device
> 8.0 on pci1
> pcm0: <TriTech TR28602 AC97 Codec>
> nve0: link state changed to DOWN
> nve0: link state changed to UP
> nve0: promiscuous mode enabled
> nve0: promiscuous mode disabled
> 
> 
> 
> 
> 
> 
> --
> Best wishes,
> 
> Alexander G. Chamandy
> Webmaster
> www.bsdfreak.org
> Your Source For BSD News!
> Hosted by Envescent, LLC
> www.envescent.com
> 

I disabled DMA by adding hw.ata.ata_dma=0 to /boot/loader.conf and now
the lockups have stopped.  This isn't the ideal solution, but perhaps
it narrows down the problem a bit more.

-- 
Best wishes,

Alexander G. Chamandy
Webmaster
www.bsdfreak.org
Your Source For BSD News!
Hosted by Envescent, LLC
www.envescent.com


More information about the freebsd-current mailing list