system resources in -current

Robert C. Noland III rnoland at 2hip.net
Wed Aug 10 00:38:22 GMT 2005


Since stepping up to 6-current just prior to releng_6 and now on
7-current, the %cpu consumed by system as reported by systat -vmstat and
top seems incredibly high. I have all of the debugging options turned
off in the kernel, as well as:

lrwxr-xr-x  1 root  wheel  4 Jul  5 18:38 /etc/malloc.conf -> ajrz

This machine is running sched_ule though I have tried 4bsd also.  It is
a Dell c640 2Ghz p4m which seems to have a broken lapic and so is using
ACPI-fast.  I have also seen this on my amd k7 1.4 tberd which also does
not seem to have lapic.  My hardware resources are constrained at the
moment, so I don't have a lot of machines to play with...

Sooo, Is this an expected behavior in -current, or am I missing some
debug options that I need to turn off.  I can't find anything else to
fiddle with.  I even tried patching the vm system from yesterdays bug
and that didn't seem to have much of an effect on this either.

anyway, thanks in advance for any suggestions, or on ways to track it
down...

it rarely ever goes below 10%, and frequently is 25 - 50% and is
generally significantly higher than user %

#top -S

last pid: 23808;  load averages:  0.55,  0.55,  0.54    up 0+01:46:06  19:34:24
138 processes: 3 running, 111 sleeping, 24 waiting
CPU states:  3.1% user,  0.0% nice, 16.0% system,  0.8% interrupt, 80.1% idle
Mem: 128M Active, 40M Inact, 100M Wired, 420K Cache, 101M Buf, 728M Free
Swap: 2023M Total, 2023M Free

  PID USERNAME    THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
   11 root          1 171   52     0K     8K RUN     74:26  9.38% idle: cpu0
  730 root          1  76    0 66380K 29468K select   5:37  0.00% Xorg
  909 rnoland       1  76    0 17100K 11960K select   1:00  0.00% battstat-appl
  905 rnoland       1  79    0 17648K 12100K select   0:47  0.00% gnome-netstat

robert.




More information about the freebsd-current mailing list