6.0-CURRENT SNAP004 hangs on amr (patch)

Mike Tancsa mike at sentex.net
Mon Aug 8 18:31:25 GMT 2005


At 01:11 PM 08/08/2005, John Baldwin wrote:

>Ok, so I'm assuming that 5.4 works but RELENG_6 does not?  Do you have 
>verbose
>dmesg's from both cases so that I can compare them?


Actually, one other datapoint that might be related, I tried out my Dell 
box netbooting a RELENG_4 image and I am able to boot with the ATA defined 
in the kernel.


Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD 4.10-STABLE #0: Tue Sep 21 10:27:52 EDT 2004
     robert at fledge.watson.org:/home/data/fbsd-stable/src/sys/compile/SMP
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium III/Pentium III Xeon/Celeron (500.02-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0x672  Stepping = 2
   Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 2147475456 (2097144K bytes)
avail memory = 2086187008 (2037292K bytes)
Changing APIC ID for IO APIC #0 from 0 to 4 on chip
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
FreeBSD/SMP: Multiprocessor motherboard: 4 CPUs
  cpu0 (BSP): apic id:  3, version: 0x00040011, at 0xfee00000
  cpu1 (AP):  apic id:  0, version: 0x00040011, at 0xfee00000
  cpu2 (AP):  apic id:  1, version: 0x00040011, at 0xfee00000
  cpu3 (AP):  apic id:  2, version: 0x00040011, at 0xfee00000
  io0 (APIC): apic id:  4, version: 0x00170011, at 0xfec00000
Preloaded elf kernel "kernel.SMP.410.20040921" at 0xc0565000.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 11 entries at 0xc00fc7a0
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82454NX PXB#0, Bus#A> on motherboard
IOAPIC #0 intpin 14 -> irq 2
pci0: <PCI bus> on pcib0
isab0: <Intel 82371AB PCI to ISA bridge> at device 2.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> at device 2.1 on pci0
atapci0: ATA channel disabled by BIOS
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> irq 0 at device 2.2 on pci0
uhci0: Could not map ports
device_probe_and_attach: uhci0 attach returned 6
Timecounter "PIIX"  frequency 3579545 Hz
chip0: <Intel 82371AB Power management controller> port 0x850-0x85f at 
device 2.3 on pci0
pci0: <ATI Mach64-GI graphics accelerator> at 4.0
pcib1: <PCI to PCI bridge (vendor=8086 device=0960)> at device 8.0 on pci0
pci1: <PCI bus> on pcib1
amr0: <LSILogic MegaRAID> mem 0xfe000000-0xfe3fffff irq 2 at device 8.1 on pci0
amr0: <Series 466> Firmware GH6D, BIOS 1.43, 32MB RAM
pcib4: <Intel 82454NX PCI Expander Bridge> at device 18.0 on pci0
pcib5: <Intel 82454NX PCI Expander Bridge> at device 19.0 on pci0
pcib6: <Intel 82454NX PCI Expander Bridge> at device 20.0 on pci0
pcib2: <Intel 82454NX PXB#0, Bus#B> on motherboard
IOAPIC #0 intpin 21 -> irq 5
IOAPIC #0 intpin 22 -> irq 10
IOAPIC #0 intpin 20 -> irq 11
pci2: <PCI bus> on pcib2
ahc0: <Adaptec aic7890/91 Ultra2 SCSI adapter> port 0xec00-0xecff mem 
0xfe902000-0xfe902fff irq 5 at device 4.0 on pci2
aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs
ahc1: <Adaptec aic7890/91 Ultra2 SCSI adapter> port 0xe800-0xe8ff mem 
0xfe901000-0xfe901fff irq 10 at device 6.0 on pci2
aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs
ahc2: <Adaptec aic7860 Ultra SCSI adapter> port 0xe400-0xe4ff mem 
0xfe900000-0xfe900fff irq 11 at device 8.0 on pci2
aic7860: Ultra Single Channel A, SCSI Id=7, 3/253 SCBs
pcib3: <Intel 82454NX PXB#1, Bus#A> on motherboard
IOAPIC #0 intpin 19 -> irq 12
IOAPIC #0 intpin 18 -> irq 13
pci3: <PCI bus> on pcib3
pci3: <unknown card> (vendor=0x8086, dev=0x107c) at 1.0 irq 12
pci3: <unknown card> (vendor=0x13a3, dev=0x0020) at 3.0 irq 13
orm0: <Option ROMs> at iomem 
0xc0000-0xc7fff,0xc8000-0xc8fff,0xd0000-0xd07ff,0xd4000-0xd47ff,0xd8000-0xd87ff 
on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A, console
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
Waiting 15 seconds for SCSI devices to settle
amrd0: <LSILogic MegaRAID logical drive> on amr0
amrd0: 34732MB (71131136 sectors) RAID 5 (optimal)
SMP: AP CPU #1 Launched!
SMP: AP CPU #3 Launched!
SMP: AP CPU #2 Launched!
pass0 at amr0 bus 0 target 6 lun 0
pass0: <DELL 1x3 U2W SCSI BP 5.12> Fixed Processor SCSI-2 device
Pcd0 at ahc2 bus 0 target 5 lun 0
cd0: <NEC CD-ROM DRIVE:465 1.25> Removable CD-ROM SCSI-2 device
cd0: 20.000MB/s transfers (20.000MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present


If I try and do this under RELENG_5 or above the computer locks up / goes 
into its hang state when loading it or the USB drivers.

         ---Mike




More information about the freebsd-current mailing list