Conflict between high resolution console and X

Mervin McDougall mcd_advisory at yahoo.com
Sat Aug 6 17:54:56 GMT 2005


Hi all
  I have been experimenting with FreeBSD 6.0 BETA 2 on
my laptop which uses a  ati radeon Mobile Utiliy 1
(IGP 320M) video vard. I have been able to configure
both high console resolution MODE_279 and X on the
laptop, however I have noticed that this error turns
up whenever I boot the system or restart X :

drm0: <ATI Radeon RS100 Mobility U1> port
0x9000-0x90ff mem
0xe8000000-0xefffffff,0xe0100000-0xe010ffff irq 9 at
device 5.0 on pci1
info: [drm] Initialized radeon 1.16.0 20050311 on
minor 0
error: [drm:pid2557:radeon_cp_init] *ERROR*
radeon_cp_init called without lock held
error: [drm:pid2557:drm_unlock] *ERROR* Process 2557
using kernel context 0

After much googling and scanning of my system, I
figured a quick way to get rid of the error message,
by disabling dri in the xorg.conf. But that is not the
only problem I discovered. I noticed that when playing
music there is constant annoying repeating of the
sound until the console displays. This only happens
when switching from X to high resolution console.
Switching back does not reproduce the problem.

Incidentally, I deleted my xorg.conf and restarted the
server in error and this cause Xorg to generate X
using its own built in defaults. Consequently this
solved the problem of the choppy  repetitive music.

Similarly, If I have a configured xorg.conf and I
restart X after booting (CTRL+ALT+BACKSPACE) the
problem goes away.
I haven't been able to pin the problem down to
discover how to get rid of the problem and still have
a workable  and have an xorg.conf without having to
restart the X server. Can anyone share their thoughts
?

Mervin McDougall


		
____________________________________________________
Start your day with Yahoo! - make it your home page 
http://www.yahoo.com/r/hs 
 


More information about the freebsd-current mailing list