/dev/x

Jayton Garnett jay at codegurus.org
Sat Aug 6 11:24:40 GMT 2005


Hello,

I downloaded the FreeBSD 6.0 Beta 1 ISO's and burnt them as per usual 
and thought great let me try install it....
I got to the sysinstall partitioning screen and allocated 20GB of my 
250GB ATA100 Western Digital hard drive.
This is where the problem starts, normally it will create the partition 
on something like  /dev/ad1s3 but in this case
it created it as /dev/X. I thought nothing of it at first thinking it 
was a new way that 6.x will be allocating the partitions.

I went on to select the normal stuff I want too install ( user + X, 
src/ALL ) and went on to try commit, I tried to commit
off the CD's, that did not work and had an error about the /dev/X, so I 
thought I would try install via FTP, the same error
popped up.

My hardware is as follows:

Jetway V266B motherboard ( 
http://www.jetway.com.tw/evisn/product/amd/v266b/v266b.htm )
Western Digital 80GB (IDE Channel 0, XP Pro only)
Western Digital 250GB (IDE Channel 1, FreeBSD 5.4, 3xNTFS, 1xFAT32)
768MB 266MHZ DDR

I use the GAG boot manager, this is not a Compaq/HP/Dell it is a custom 
built system.
I found a bug report about /dev/X being created as a hidden partition 
for XP, but since mine is not a OEM XP Pro
it should not create a so called hidden partition that would produce 
this failure (as far as I know) and if it was down to that
surely FreeBSD 5.4 would have had a similar problem.


I have 'deleted' (but not commited) the other partitions and created a 
partition too see if that helped and it did, however I can not
delete the other paritions and commit as I have too much data that must 
not be lost and too much too backup on CD/DVD.


Why is this happening? What can be done too fix it?

Other links for reference:
http://www.freebsd.org/cgi/query-pr.cgi?pr=i386/39604
http://www.freebsd.org/cgi/query-pr.cgi?pr=i386/84008

I have submitted this problem to the FreeBSD guys via the bug report on 
the FreeBSD website aswell.

-- 
Kind regards,
Jayton Garnett

email: jay at codegurus.org
Main : www.uberhacker.co.uk
Test server: jayton.plus.co


More information about the freebsd-current mailing list