Panic on FreeBSD 6.0BETA1

Derrick Edwards dantavious at comcast.net
Thu Aug 4 04:24:35 GMT 2005


   Hi all,
I decided to try and help with testing 6-BETA1, after updating sources and
recompiling i get the following during boot up. I am tried booting without
hyperthreading enabled in the bios and I still get the same panic.

Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id =00
fault virtual address = 0x480008
fault code = supervisor read, page not present
instruction pointer = 0x20:0xc06923cc
stack pointer = 0x28:0xc10208ec

Code segment = base 0x0, limit 0xfffff, type 0x1b
             = DPL 0, pres 1, def32 1, gran 1

processor eflags = interrupt enabled, resyne, IOPL = 0
current process = 0 (swapper)
[thread pid 0tid0]
Stopped at strlen+0x8: cmpb $0,0(%edx)

I left all the debugging features in the current however, I am not sure
exactly how to trace this problem. If someone could point me to any doc that
would allow to provide more information that would  be great. I updated my
pen 400MHZ using the same procedures and all went well. Please help

CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (1866.74-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
 
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,
CMOV,PAT,PSE36,CLFLUSH,D TS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Hyperthreading: 2 logical CPUs
real memory  = 1073676288 (1023 MB)
avail memory = 1036931072 (988 MB)
ACPI APIC Table: <IntelR AWRDACPI>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1




Thanks for your assistance
Derrick




More information about the freebsd-current mailing list