if_ipw problems

Niki Denev nike_d at cytexbg.com
Wed Aug 3 05:05:24 GMT 2005


Sam Leffler wrote:
> 
> You say things work with ral but not ipw?  Was that with wpa-psk and the 
> same ap?  Have you ever been able to use ipw and wpa-psk?  I don't 
> personally know if it works and the driver's author has been out of 
> touch for a long time.
> 
>     Sam
> 

It worked with ral, but with some problems, it would associate after a
while, then the next time i try it won't, after a couple of minutes it
will succeed again.
This happens when i try to use ral interface to connect to an AP with
WPA-PSK.
I've tested both interfaces on two APs, one is Linksys WAP54G the other
is my home router/gateway which is 6.0-CURRENT with ral in hostap mode.
Both APs work ok when i try to connect with windows machine,
The only problem with the ral AP is that after several days uptime
the SSID stops appearing to the wireless clients that scan for it,
and ifconfig up/down + restart of hostapd is needed.
Wpa-psk + ipw never worked for me regardless of the AP i tried.

I'll continue to dig in search of the problem. I initialy thought
that it has something to do with this zero macaddr entry,
but as you say that it shouldn't matter i will look elsewhere.

I'm also experiencing another repeatable problem with ipw -
(when used with static WEP)
cvsup always fails with Network TreeComp failed or something,
everytime on different part of the source code.
I've done some tcpdump traces and will check what it may be.
This is also happening on both of the APs i use, the linksys
and the freebsd one.
This problem appeared with the later versions of the ipw driver
(after importing it in freebsd), the previous versions
from http://damien.bergamini.free.fr/ipw/ worked ok.

Thanks


--niki


More information about the freebsd-current mailing list