if_ipw problems

Daniel O'Connor doconnor at gsoft.com.au
Wed Aug 3 02:19:53 GMT 2005


On Wednesday 03 August 2005 05:22, Niki Denev wrote:
> When using exactly the same wpa_supplicant config with different wireless
> card (ralink) i can authentitace to a LinkSys WPA54G access point.
> But it never works for ipw.
> One thing that i discovered is that when i do ifconfig ipw0 scan
> there is always one 'fake network' without SSID and with zero macaddr :
>
> # ifconfig ipw0 scan
> SSID           BSSID                      CHAN      RATE   S:N     INT CAPS
>                   00:00:00:00:00:00   11          0M     0:0        0
> office.ss      00:0f:66:11:13:1e   11         54M    29:0  100  EP WPA
>
> This looks really odd, and i can't reproduce it with other wlan cards.
>
> i cancelled it at this point, but it loops like this forever(or atleast
> couple of hours :) )

I get exactly the same thing here - it appears to try and associate with the 
right AP (ie ignores the 00:00.. one) but it doesn't print any error or 
warning about why it can't do so.. It just retries every 5 seconds forever.

Have you tried NDIS for your card? I had a go, but it panic'd :(

-- 
Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050803/7aa6c542/attachment-0001.bin


More information about the freebsd-current mailing list